Sediment Delivery Ratio model error

Hi, I am trying to do SDR in InVEST 3.7. I run the model for 8 hours, but this is the only thing showing up. Almost all of my inputs are good, but I don’t know why this shows up. Please Help. Thank you in advance!

Hi @anniemaeinson, offhand, I’m not sure what’s happening here, but the model probably should have done something in less than 8 hours :slight_smile: Could you share your inputs with us so we can try to reproduce this issue on our end?

Thanks!
James

1 Like

These are my inputs:

  1. the DEM raster file of the watershed
  2. rainfall erosivity index in raster file
  3. soil erodibility index in raster file
  4. LULC raster file
  5. watershed boundary (in shp file)
  6. biophysical table (I followed the right column title)
  7. Threshold flow accumulation (1000)
  8. borseli k parameter (1.096)
  9. Borseli IC0 parameter (0.5)
  10. Max SDR value (0.8)

Here’s the log file:

InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2019-09-16–09_37_55.txt (1.3 KB)

Thank you very much. This is my first time using InVEST, so I appreciate your help very much.

Hello, I recently tried to run the program in a windows computer, and this came up:

InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2019-09-23–09_07_15.txt (6.6 KB)

Well, still not sure what’s going on in the mac build there. If you can attach your inputs (or send them via google drive, dropbox or the like) we can try to reproduce the issue.

In any case, the second error log looks like there are pixel values of -infinity in your landcover raster, and -infinity (-3.402823e28) is not in your landcover csv. Could you check and make sure that this is a valid value for your raster? Often times values like this are supposed to be nodata values, but the nodata value of the raster isn’t actually set correctly.

Let us know how this goes,
James