The program does not work or open

Hi @timber , invest is compatible with Windows 10 - I’m running it now - but there must be something unique about your system. We would like to figure that out and fix the problem for you and others, but we need more information.

Well what actually happened? Did you run a command like C:\InVEST_3.9.0_x64\invest-3-x64\invest.exe --debug run sdr? If you did this and got the same “not recognized…” message then it means there is still a mistake in the filepath of invest.exe. Can you tell us the filepath of your invest.exe file?

What exactly did you do when you say “run a troubleshoot”? And what exactly was the result?

Thank you,

1 Like

Hi @dave and @jdouglass. I am having the same problem for a new installation on Windows 10. Black screen that briefly opens and then nothing. Image below is what I’m getting running the suggested command in command prompt. Any help is appreciated. Thank you.


Hi @rtga , thanks for reporting this issue. We’ve had a few of these reports recently. I might have a development version of invest that fixes this. Do you mind trying this installation:

Please let us know if it solves the problem.

Alternatively, it might be possible to edit your PATH environment variable to get things working, as described in this thread:

But I don’t necessarily recommend that approach.

Thanks @dave for the quick reply. I tried the installation you shared and still have the same problem. Also tried using the command prompt (screenshot). Thank you for linking to an alternative solution, though I’m a bit hesitant since you recommend against it. Thanks again! – Ryan.


Well that’s too bad. Thanks for the feedback. That alternative solution could be worth a try until we figure out why this is such a problem. Just be aware that other software you have is probably also using those PATH entries, so it’s important to be careful when changing them, and maybe be prepared to change them back if something else breaks.

In the cmd prompt, if you enter echo %SystemRoot% you will see what that variable is supposed to expand into (for me it’s C:\Windows). And then you could edit the PATH entry %SystemRoot%\system32 changing it to C:\Windows\system32.

Hello, I encountered the same problem when running the software after I installed InVEST3.9.1. I still can’t open it by using CMD command. Can you help me?

Hi @wangyi , It’s a bit difficult to describe the solution. Could you show screenshots of your PATH environment variable, as was done on this thread:

There is probably one or more entry in the PATH that might need to be modified. Thank you,

Hello, teacher. This is my environment variable, and for viewing convenience, I have copied it into TXT. Thank you very much for your kind help.

Dear teacher, I have replaced “%Path%” with “C:\Users\ Lenovo” in the setting of environment variables according to the content of the linked post in your reply. Now the software can be opened normally. Thank you very much for your enthusiastic answer, which will be of great help to my graduation thesis! :wink:Thanks again!

Great to hear! Please remember that other software on your system also uses that Path variable, so if you notice that something else does not work as expected, be prepared to reverse your changes.


@wangyi @rtga would one of you be willing to try the development build I have linked below? I’m fairly certain it will fix the issue of InVEST not opening, but I’d really appreciate your help in confirming that it does work. Please let us know if it doesn’t work!

Thanks in advance,

Hi @jdouglass. I am able to get InVEST to open with this new build.

I get the following warning in the command prompt window that opens at the same time as InVEST.



1 Like

Thanks for trying this build out @rtga ! I’m glad it’s running.

That warning isn’t anything to worry about, but we’ll take care of it in a future release.


Hello teacher, I tried the new version of Invest software you released, you can directly open it through the shortcut! Thank you very much!

Hi James, I’ve tried downloading all of the versions in this thread and can’t seem to make it work.
I’m running windows 10.

I could make the Carbon model run saving the invest folder in c:/ instead of in c:/programs
Then running it as in \invest.exe run carbon, but when I want to run the Coastal Blue Carbon I get:

C:\Users\ines_>C:\Users\ines_>C:\Program Files\InVEST_3.9.0.post579+g89107e76_x64\invest-3-x64\invest.exe run Coastal Blue Carbon
Access is denied.

Would appreciate any help. Thanks

Welcome to the forums @inespereda !

From a terminal, could you try running the following command?

"C:\Program Files\InVEST_3.9.0.post579+g89107e76_x64\invest-3-x64\invest.exe" run "Coastal Blue Carbon"

From what you’re describing, the error message could very well be because of the missing quotation marks. Without them, Windows is looking for a program called C:\Program instead of looking within the Program Files folder, and the quotation marks clarify exactly which program Windows should be looking for.

Let us know how this goes!

Hi James, thanks for the quick reply, I’ve never worked directly from the cmd so that made sense.

I’ve tried from invest in the program files folder and:
C:\Users\ines_>“C:\Program Files\InVEST_3.9.0.post579+g89107e76_x64\invest-3-x64\invest.exe” run “Coastal Blue Carbon”
Error: ‘Coastal Blue Carbon’ not a known model

Then I’ve tried that placing invest directly from the c drive and:
C:\Users\ines_>“C:\InVEST_3.9.0.post579+g89107e76_x64\invest-3-x64\invest.exe” run “Coastal Blue Carbon”

Access is denied.


Whoops! Sorry about that … I didn’t check the label that the command-line interface recognizes.

If your InVEST installation is within C:\Program Files, then this should launch Coastal Blue Carbon:

"C:\Program Files\InVEST_3.9.0.post579+g89107e76_x64\invest-3-x64\invest.exe" run coastal_blue_carbon

But also, you should be able to find a “Coastal Blue Carbon” shortcut in your start menu … that should be easier to launch than using the command-line. Keep in mind that the start menu shortcut will only work if the InVEST installation is exactly where the installer put it. So if the location has changed, you may need to re-run the installer.

Hope this helps,

Thanks James, the underscores did the trick.

That is the issue though, whenever I look it from the start menu, it opens a cmd window that does nothing, wont let me type anything to it and no GUI.

Well that’s interesting! The CMD window is opening, so the start menu link is probably pointing to the right place. I’m not completely certain what’s going on there, since you can clearly run the application itself through the command-line interface.

What version of Windows are you using? Sometimes antivirus software can have unexpected effects on software … If you do have antivirus running, will InVEST run as expected if you temporarily disable antivirus?