DelineateIT Error

Hi all,

I am having trouble using the tool. This is the log that comes out after I run it:

Initializing…
Showing messages with level INFO and higher
2020-09-10 14:26:16,252 execution.run(78) ERROR Target <function InVESTModel.execute_model..logged_target at 0x0C05CA08> failed with exception
Traceback (most recent call last):
File “site-packages\natcap\invest\ui\execution.py”, line 68, in run
File “site-packages\natcap\invest\ui\model.py”, line 1621, in logged_target
File “contextlib.py”, line 112, in enter
File “site-packages\natcap\invest\utils.py”, line 108, in prepare_workspace
File “contextlib.py”, line 112, in enter
File “site-packages\natcap\invest\utils.py”, line 189, in log_to_file
File "logging_init
.py", line 1087, in init
File "logging_init
.py", line 1116, in _open
PermissionError: [Errno 13] Permission denied: ‘C:\Users\Desi\Documents\delineateit_workspace\InVEST-DelineateIt-Watershed-Delineation-log-2020-09-10–14_26_16.txt’
2020-09-10 14:26:16,284 execution.run(83) INFO Execution finished

In the Outlet Features field, I used a vector outline with a cropped outline of a municipality.
What could be the problem?
Thanks in advance!

Hi @deschoni -

Welcome to the forum!

Since the error is Permission Denied when trying to create the log file, have you checked to make sure you have write permission for your Workspace folder? If that is not a problem, which version of InVEST are you using?

~ Stacie

Hi,

I don’t know how to check if I have permission for Workspace folder, except for the green symbol (✓) on the left. On your second question - I use the latest version of InVEST 3.8.8.

Thanks for the quick response,
Desislava.

Virus-free. www.avast.com

На чт, 10.09.2020 г. в 19:06 Stacie Wolny via Natural Capital Project Online Community <naturalcapitalproject@discoursemail.com> написа:

Hi @deschoni,

This is interesting because the green ✓ should not show up if you don’t have write permission to the workspace folder. Could you please share what version of Windows you are using?

Thanks,
Emily

Hi again,

I’m using Windows 10. I used InVEST 3.7.0 Visitation: Recreation and Tourism some time ago and I didn’t have such a problem on the same computer.

Thank you,

Desislava.

Virus-free. www.avast.com

На чт, 10.09.2020 г. в 19:59 Emily Soth via Natural Capital Project Online Community <naturalcapitalproject@discoursemail.com> написа:

Hi @deschoni,

A couple of things to try:

  • Does this happen every time you try to run the model?
  • Do you use Dropbox, OneDrive, or another similar service with your Documents folder?
  • Are you running low on disk space?
  • Can you try using a different workspace location? You could change the workspace input to something like C:\Users\Desi\test_workspace (outside of the Documents folder)

Hi @esoth,

I was already trying to change the folder (on Desktop), for which I also had permission, but the result was the same error.
The other questions: yes this happens every time I run the model; the folders I use are not related to Dropbox, etc .; I have enough space on the computer.

Hi @deschoni,

One more thing to try would be running InVEST as an administrator. Right-click on the InVEST executable and click ‘Run as administrator’.
If that doesn’t work, could you try using a previous version of InVEST, like 3.8.0, and see if that helps?
Also, are you able to create a file in the workspace directory using another software program? (e.g. save a text file there)

Thanks for helping us improve InVEST!

Hi again @esoth,

I just tried to run the model as an administrator and again the same error.
In the folder that is set as Workspace, I can create new files as well as copy other files.
These days I will try version 3.8.0.

Thanks for all the advice,
Desislava.

Virus-free. www.avast.com

На пт, 11.09.2020 г. в 18:37 Emily Soth via Natural Capital Project Online Community <naturalcapitalproject@discoursemail.com> написа:

Hi @deschoni, thanks for your patience with this issue, and I’m sorry we don’t have an obvious solution for you at the moment. Please do let us know if it isn’t working after trying the various things you describe (including trying the latest version of InVEST, version 3.8.8) and we can try to keep debugging this.

Thanks,
James