HQ Model - Error - Bounding Boxes Do Not Intersect

habitat-quality
#1

Hello,

I am receiving an error on my habitat quality model. It is giving me a value error that my bounding boxes do not intersect. I have looked up this issue on the web as well as the old forum however I have not seen any solutions or explanation as to what these boxes are. I would like to know how I can intersect these bounding boxes and what they are.

I have attached my log file and the screenshot of the error as well.

Thank you for your assistance!

InVEST-Habitat-Quality-log-2019-04-23–14_53_07.txt (2.4 KB)

#2

Hi @nadia -

Often “bounding box” errors happen when your input spatial data is not all in the exact same projected coordinate system. The bounding box is the spatial extent of the data, and obviously they need to overlap in order to do calculations. Check your coordinate systems, and even if one is slightly different than the others, reproject/Warp so they are exactly the same.

~ Stacie

1 Like
#3

Hello @swolny

I have just warped all five of my layers to have the same projection coordinate system. It took a while but everyone of my layers from the land cover one to the threat layers all have the correct and exactly same coordinate systems, however I got the same error again. It shows me five different projection coordinate systems and one appears to be off because it does not have the first two values and is complete out of the range from what I set to all of my layers. I am not sure how to go on with this issue.

Here is my log file from my most recent attempt: InVEST-Habitat-Quality-log-2019-04-24–14_25_30.txt (2.4 KB)

I really appreciate you help!

#4

Well then I might need to check them out to see what’s happening - can you send me your input dataset? swolny@stanford.edu.

~ Stacie

#5

Yes absolutely! Thank you so much for taking the time to help me out.

#6

Thanks for sending me your data, Nadia.

First, when using ESRI GRID format as raster inputs, give the “hdr.adf” file as input to InVEST. You were giving it the “.ovr” file, and that produced the bounding box problem. When I gave it hdr.adf, it got past that error. TIFFs are way easier to use then GRIDs, and I’d recommend using them if you can.

Next, InVEST still has some strange issues with telling you that there are LULC values missing from the sensitivity table, when those LULC values don’t exist in the original raster. In this case, it complained about finding a value of “-32768”, which is not even the NoData value for the LULC, so I’m not sure where this value is coming from. Anyway, I added an entry for lucode -32768 to the sensitivity table, with corresponding field values of all 0, and that fixed that, and the model ran to completion.

However… The output habitat quality values are all either 0 or 1, nothing in between. The degradation raster has a low value of -5e+37, which is also not good. One thing of note is that “lake_c” has values of 0, 1 and NoData, and the threat rasters should not have any NoDatas, so I changed those all to 0 (based on a previous forum post), but that didn’t change the weird low values in degradation. Several of the “filtered_*” intermediate outputs have oddly low values, which might contribute.

Also, none of the intermediate or final output rasters have a coordinate system set. I have no idea what’s happening there, because the inputs are consistent. And I was not able to find a solution to the 0/1 only output problem on the previous forum (hopefully this new forum’s search works better!) So I’m going to have to punt this to @jdouglass for further debugging - James, I can send you the input data that I’m using.

Oh, and I’m not sure what’s up with the threat *_f rasters, but they look strange in a GIS, with values to 65534, and a supposed size of 37GB. Nadia, you’ll want to work on these more before trying to use them in the model.

~ Stacie

1 Like
#7

Hello @swolny ,

Thank you for your indepth review on the case I am dealing with, it is very much appreciated!

I will use the “hdr.adf” file to input for the current land cover layer instead of the “.ovr” file. It was not specified in 4.1.4 data needs of the current user guide therefore I chose the largest file as I assumed it would have the data it needs to run the model. I will make a note of this and use TIFFs instead of a GRID in the next model run after I work on the following tasks below.

I am not sure why there is a value of “-32768” either as it is not a value I have marked anywhere in the process of creating these layers and tables. I have also put in the entry for this number in the sensitivity table to run the model when I got this error and then bypassed it to the bounding box error at one point with some older data in the project I am working on from previous years and it was able to run successfully.

I have used your advice and now I was able to run the model to completion as well. I see the odd output habitat quality values as well though I have no idea why the habitat quality values are either very low or 0/1. Shall I edit the NoData values within the lake_c threat raster on it’s attributes table? I see that note in the user guide as well, I apologize for that mistake and will change the values to 0.

For the future threat rasters, I exported the current threat rasters with 16bit unsigned which may have been the problem at it has a greater range of values that each cell can contain. I will export those using a lower range of values like unsigned 8 bit. I will re-export the future threat rasters and change the no data values in the lake_c threat raster and review the outputs to understand better these problems we are facing.

Thank you for directing this issue to @jdouglass I look forward to hearing your input about the 0/1 habitat quality outputs, missing coordinate systems, and low degradation values. I really appreciate the effort you have shared to help me with these issues @swolny , I will work on them and correct my methedoogy befor eI use the data in the model.

I will be heading out of my office in an hour and be back tomorrow around 7am CT and respond to any replies promptly! Thank you everyone!


Hello all,

I have started exploring the output habitat quality raster and I can see some values in between 0 and 1 however there is no attributes table or frequency table where I can view everything that is showing on the raster unless I zoom into areas. When I try to change the symbology to unique values it does not work as it states that the number of unique values I have in the data is greater than the set limit of 65536. I’m not sure if I should change the maximum number of unique values.

I can see degradation layer has very low values as well though I am not able to view a table for it either. Neither of these output layers have a coordinate system attached to it as is on a compleltly differnt area than the rest of my layers.

I will change the bit depth of the threat layers and rerun the model and try to change the no data values of the lake_c threat raster tomorrow morning and report back as soon as possible.


I quickly wanted to add that a lot my layers that I used to create the threat rasters and land cover layers are all swked. None of them have projections coordinate systems suddenly after I ran the model. They all had WGS 1984 Web Mercator Auxiliary Sphere, however they do not now and they are not on the country they originally were. My basemap has also turned horizontal…I’m not sure what happened though before during my failed model attempts my csv files kept getting combined into one field from multiple fields.

I am not sure if the InVEST 3.6 model is reworking some of my data, shall I download older InVEST versions? I will work on fixing all of these layers.

Thank you.

#10

Hello all,

I have worked on this a bit more yesterday and I have some updates. Though I am not sure as to why the projections are missing from my output results, I have defined projections for the output files with ArcGIS Pro.

I changed the no data values in my threat rasters to 0 by reclassifying the nodata value. As well as created future threat rasters with the correct bit depth. I spoke with my supervisor and we concluded that the results we were viewing fell in line with what we has expected to see. In our habitat quality output for the current landscape, we can see values in between 0 and 1 when we zoom into the raster. Comparing to previous years results for the habitat degradation of the current landscape, the low values fall not far on the range of acceptability. Also we re ran the model with the updated threat rasters the degradation value ranges from 78.6679 to -1.00052e-13 which is where we are retrieving our understandings from. Therefore after exploring these results we will be continuing onto scores and calculating areas.

I look forward to hearing more about the bug about missing coordinate systems from intermediate and final outputs. I have noticed that at times when I ran the habitat quality model in InVEST 3.6.0 and it failed, my sensitivity and threat tables were altered and pushed into one field instead of the original data when everything as organized as one. Also after successfully running the model, some of my boundary layers and raster images lost their spatial references and my base map was flipped and distorted. I am not sure how that is happening, though I thought I should share these issues.

Thank you so much for all the time and effort everyone has put into assisting the issues I have faced. I really appreciate it!

  • Nadia Noori
#11

Thank you for the update, Nadia. I think you can safely set the degradation values that are very small negatives to 0. It’s also interesting to know that you are now seeing values in between 0 and 1, and I wonder what changed that. Really, you should be seeing a good, obvious spread of values.

Glad that you can move on with your analysis at least.

~ Stacie

#12

Hello @swolny ,

When I explored the degredation output, I can see that the extreme low values are only near the edge of the boundary of the county I am working with. I think that might have something to do with it because when i checked everywhere else on the raster those values weren’t present. I just saw values withing the 0-1 range. I’m not sure why those values are so high nearing just the border and why the border itself are in very small negative values. I have labelled those low degradation values with zero.

I re-clipped my threat rasters as I realized that I was clipping them to a folder and not a geodatabase, which was why I wasn’t able to get a clean cut of the layers. After I did that and chose a different half saturation constant from 5 to 0.5, I was able to see a obvious spread of values as you mentioned. After retracing and changing the computational errors, I am able to see better results that we can make analyses with.

Kind regards,
Nadia Noori

#13

Hey @nadia and @swolny,

So it looks like there are a couple of issues happening here:

Coordinate systems
I’ve just started looking into this, and there seems to be a low-level issue with GDAL recognizing the projection information in the ESRI binary grids.

As @swolny mentioned, none of the outputs have a spatial reference set. Interestingly enough, when I inspect the inputs with GDAL, none of the binary grids claim to have a projection set either. The modified lake_c.tif does have a projection set, specifically EPSG:3857, so this makes me think that there might be an issue with GDAL reading projection information from binary grids. To top things off, GDAL has had a longstanding issue with handling web mercator, that looks to still be a problem in the latest versions of GDAL, and is especially surprising given just how common Web Mercator is these days.

So, to correct the issue of the missing projections, could you try a different projection? Your local UTM zone would usually be a good bet for this and is typically handled very well by GDAL.

LULC values missing from the sensitivity table
We’ve fixed this in a recent development build (here’s the download link), which will be included in a soon-to-be released new version of InVEST.

Low pixel values at the raster boundaries
I’m not quite sure what’s causing this one, but maybe it’s been fixed in the dev build linked above? When I run through the HQ model with the dev build, Habitat Quality (quality_c.tif) seem to be as expected, ranging from 0 to 1. There are continuous values there as well.

Even so, I’m glad that you’ve found a workaround.

Degradation values having a crazy range
In the data the Stacie sent me, hydro_c had pixels with values of 0, 1 and nodata. I’ve historically had issues in HQ when threat rasters have pixels that represent nodata, which can lead to very high or very low values like what you’re describing. When I reclassify the pixel values to create a new hydro_c.tif, the degradation outputs look more reasonable, but I’m still seeing some very low values and haven’t yet pinpointed why they’re there.

Still, they do seem to be at the County’s edge like you say, so maybe scaling from 0-1 and clipping out some of those values is a good-enough workaround for the time being? I’m still going to look into this a bit more to see if I can find the cause.

Hope this all helps, and thanks for working through the debug with us!
James

1 Like
#14

Hello @jdouglass and @swolny ,

Thank you for your message, it means a great deal! Here is what I have come up with so far…

  • Coordinate Systems

I changed all of the projection coordinate system from WGS 1984 Web Mercator Auxiliary Sphere to WGS 1984 UTM Zone 14N. The model’s this time ran quite smoothly, about half the time it took before! The outputs included the coordinate systems as well and projected correctly on my base map.

  • LULC Values and Low Pixel Values

As of now I have requested to download the developmental build to the admin of our research center and as soon as they give me permission, I will be able to get past the missing values. Though for now I just wrote in the missing value as a place holder to expedite the process.

I will explore the pixel values to see if they are any different (higher) in the new developmental build. I am not sure why they are as low as they are in the edge of the rasters. Though the boundary I created skirts a 10km buffer around the actual county I am looking at, therefore I think it’s safe to use the data within that has a spread of values.

  • Extreme Degradation Values

Even in the new model run with the updated coordinate systems and threat rasters with only 0,1 values, there are no signs of changes on the very low degradation values. It is still under the -5-8 e+37 range, and I think at this point I will just clip the edge and set those low values to zero as we won’t count values under zero in analysis.

A new problem however, every time I ran the model up to now with these updates and changes, there is nothing shown on the degradation output. The raster is a blank white polygon within the boundary that I specified. When I hover over the raster layer in catalog withing my geodatabase, I can see a glimpse that there are features within it, however when I bring it onto my base map I can’t see anything on it. When I click around on the raster, i can see a spread of values throughout the raster.

Thank you Mr. Douglass and Ms. Wolny for taking the time to explore these issues with me! I am learning quite a lot about InVEST through these trial and errors.

Warm regards,
Nadia Noori