InVEST Habitat quality SystemError

There was a problem when I ran the habitat quality module of invest (version 3.10.0). The data used was the sample dataset of the software. I don’t know how to solve this problem.
Please look at this question for me.

returned a result with an error set
I attached the screenshot of the error

InVEST-Habitat-Quality-log-2022-04-13–20_53_08.txt (19.9 KB)

Hello @Hongye , welcome to the forums and thanks for including your logfile!

This error doesn’t look like anything that is likely to be directly caused by the sample data, and I don’t think we’ve seen this particular error before.

Could you try running another InVEST model (how about InVEST Carbon Storage and Sequestration?) and see if you get the same error?

I see you’re running InVEST 3.10.0, so could you try downloading and installing the latest version of InVEST from our download page and see if that version is able to run?

Let us know how these go!
James

Thank you very much @jdouglass . I updated the software to the latest version 3.10.2 and reran the Habitat Quality module, but unfortunately the problem reappeared. I switched to a different computer and ran the program again and still have the problem. I have run other modules besides the Habitat Quality module and all have this problem. Also, I think the installation of the InVEST program should be very simple, no additional programs are needed, just default to clicking Next. This is very distressing to me. I have attached a screenshot and two log files of the software where the error occurs.


InVEST-Carbon-Storage-and-Sequestration-log-2022-04-14–08_53_04.txt (14.8 KB)
InVEST-Habitat-Quality-log-2022-04-14–08_54_56.txt (10.4 KB)

1 Like

Hi @Hongye , I’m sorry for the delay in getting back to you! As distressing as this is for you, it’s very distressing for us as well because of how deep this error appears to be.

Would you please attach your threats table to this thread? I have a hunch that might help us identify the source of the error.

Thanks,
James

1 Like