Module 'natcap.invest.coastal_blue_carbon' has no attribute 'execute'

Hello, I am using the invest api to test some models, and when I have to execute the model xx it gives me an error that it does not have the execute argument.

try the same way as the official documentation indicates which is: natcap.invest.coastal_blue_carbon.coastal_blue_carbon.execute

but it indicates the error of:
AttributeError: module ‘natcap.invest.coastal_blue_carbon’ has no attribute ‘coastal_blue_carbon’

Logically I tried deleting a part of coastal_blue_carbon since it is repeated, but when I do that I get a new error that says:

module ‘natcap.invest.coastal_blue_carbon’ has no attribute ‘execute’

Im using natcap.invest 3.13.0 I updated it today to test from 3.12.1 to 3.13 and the error continues

Thanks ! and I’m sorry if the question does not correspond here but I did not find another place to ask

Hi @Bustita11 , and welcome to the forums!

When I go to import coastal blue carbon, both of these work for me:

import natcap.invest.coastal_blue_carbon.coastal_blue_carbon


from natcap.invest.coastal_blue_carbon import coastal_blue_carbon

where args is your arguments dictionary.

If the above doesn’t help or you’re still getting the same error, could you attach your python script here so we can take a closer look?


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.