NDR 3.7.0 showing Something went wrong when adding task n load (16), terminating taskgraph

I ran into an error and can’t figure out what wrong with my raster. The ndr model failed after about 40 min showing the load_n can’t be written. I checked the load_n in ArcGIS and it seemed weird.
btw, I tried with version 3.8.0 and it presented another error 35.
please help me

InVEST-Nutrient-Delivery-Ratio-Model-(NDR)-log-2020-04-30–15_42_03.txt (290.6 KB)

Hi @dana -

If you do a search on this forum for “KeyError: 128” you’ll find two posts that talk about this particular issue, including giving some ideas for how to solve the problem or work around it. Please check them out and let us know if any of the suggestions work for you. If not, we’ll be happy to help troubleshoot further.

~ Stacie

Hello @swolny
I read the post you mentioned and checked my lule data. It actually had -128 as nodata although I didn’t find it in the raster. I added 128 to biophysical table and ran. Unlukily, I ran into the key error35 that happened as I have tried with version 3.8.0. Can you help me?
Many many thanks for your time!
Here is the table:
the error:
the log:InVEST-Nutrient-Delivery-Ratio-Model-(NDR)-log-2020-04-30–23_30_42.txt (35.7 KB)

@dana, from your logfile, it looks like you’re running InVEST version 3.7.0.post537+h1fb1875d7f96. I’d definitely suggest running the latest version of InVEST, 3.8.0 if possible, which you can download from https://naturalcapitalproject.stanford.edu/software/invest.

The error you’re getting, KeyError: 35 is stating that your landcover raster has pixels with landcover code 35 and that landcover code 35 is not in your biophysical table. Based on the screenshot you provided above, landcover code 35 is indeed missing.


Thank you so much! Your suggestions did help!
I used the extract by mask in ArcGIS and set nodata 15 while modify biophysical table accordingly. The problem was dealed. It succeeded with version 3.7.0.post537+h1fb1875d7f96 but failed with version 3.8.0. Please let me know if there is anything wrong if I used the output data of 3.7.0.post537+h1fb1875d7f96?
Here is the screenshot of log of version 3.8.0 (I can’t upload successfully for some reason). I saw similar posts and tried to fill DEM for several times but all failed.

Here is the log of version 3.7.0.post537+h1fb1875d7f96
InVEST-Nutrient-Delivery-Ratio-Model-(NDR)-log-2020-05-01–01_15_39.txt (76.6 KB)

OK! Well, in this very specific case, this error in InVEST 3.8.0 is caused by an issue with GDAL that will be fixed in a future release of InVEST, so your best bet will be to keep using the development build you’re using, 3.7.0.post537+h1fb1875d7f96, until we release this fix in an updated version of InVEST.

OK!Thank you very much!