An issue on the Rangeland production model (RPM)


I am recently using the rpm and it returns an issue I do not understand. Could you help me with it?
The log is attached. Thank you very much!

Rangeland-Production-Model-log-2021-11-27–17_10_09.txt (4.7 KB)

Hi @urgendalai,

Thanks for posting to the forum and including the log file. I think @GingerK is still the go-to for this model.



Thanks for tagging me, Doug!

Hello @urgendalai ,
Sorry about this error message, it is not very informative. It looks like the model is seeing some values in your site spatial index (C:/Users/boxxx032/Documents/RPM data/site_index.tif) that do not have a corresponding entry in the site parameter table (C:/Users/boxxx032/Documents/RPM data/site_parameters.csv).

For every pixel value in the site spatial index raster, there should be a corresponding row in the site parameter table. Here is an illustration of how that works.

Does that help?


Thank you very much for your help, @GingerK !
I was able to fix this error but there is another error that appears now. Same to the last one, I don’t know which raster this error points to. It says two values are not valid but there is no raster that contains those two values?

The log file is attached, thank you!
Rangeland-Production-Model-log-2021-11-29–14_04_40.txt (44.0 KB)

Hi @urgendalai ,
It looks like the issue is with your site spatial index raster again - the model is finding pixels with values equal to 25, and 255, and not seeing corresponding entries in the site parameter table. But this is only after the model has aligned all of your spatial inputs and stored the aligned copies in C:/Users/boxxx032/Downloads/work_space/aligned_inputs/. It looks like the nodata value for many inputs (temperature, precipitation, clay, and pH) is undefined, and I wonder if that is causing the problem.

I would suggest using GDAL or QGIS to define the nodata value for all of your temperature, precipitation, and soil rasters. I hope that helps!

Thank you for your advice however, I could not find any rasters that contain a value of 25 or 255. All my nodata values are set as -999. I am very confused. I have uploaded the site map as an example, do you mind giving it a look?
Thank you very much!

site.tif (21.1 KB)

Hi @urgendalai ,
I see the issue. Your site raster is saved as a data type (2 bit unsigned char) where the assigned nodata value (-999) is not valid. When RPM uses GDAL to read this raster, it decides that the nodata value is undefined since the value -999 is not a valid value for this data type.

You will need to change the data type of each of the rasters for which this is the case (looks like you have a similar issue with your temperature, precipitation, and soil rasters) - I would suggest using 8 bit unsigned, with a nodata value of 255. You can do this in ArcGIS by using the Export Raster tool and paying careful attention to the “Pixel Type” and “NoData value” arguments.

Thank you for your help, @GingerK . I think it is fixed so no more this error. However, the model is keeping report errors that are not really informative. It can not help me identify which file or location the problem appeared. Hence I have to ask you again.

Rangeland-Production-Model-log-2021-12-27–15_37_20.txt (112.0 KB)

Hi @urgendalai ,
In the logfile, look at line 46. There is a warning on that line: “No mask value was passed and target nodata is undefined”. Here the model is working on aligning and resampling your raster “clip_min_wc2.1_2.5m_tmax_2010_1.tif”.

You need to take care of the data type and nodata value for this raster, like you did for your site index. And do the same for all of your temperature and precipitation rasters.

As long as you see a warning message like this in the log file, your inputs are not yet correctly formatted. The model will fail at some point down the line.

1 Like

Hi @GingerK ,

Thank you for your patients and help. I have fixed all Nodata issues and think the process should be close to fully running soon. Hope it is the final question to ask. The new attempt has reported the issue of the Animal grazing area. Seems a missing value is in the polygon or another input? I do not know which “base raster” it refers to, the site index?

Rangeland-Production-Model-log-2022-01-03–20_32_01.txt (114.3 KB)

Hi @urgendalai , I’m glad you were able to correct the previous issue!
This may take some debugging. Could you please take a screenshot of the folder “C:/Users/boxxx032/Documents/RPM data” showing the location of the pft rasters? (For example, I expect to see one more rasters with names like “pft 1.tif”, “pft 2.tif”, etc.) I wonder if the error is in the veg_spatial_composition_path_pattern input.

Hi @GingerK , my pft raster was named as the guidance suggested, such as pft_1.tif. I have changed to pft 1.tif and the error does not appear anymore. The model was run succeeded. However, the information seems confusing since the sample data shows no space between and the instruction on executing window shows “_” mark.

There is another problem with the value “dec_4” in the site parameter table. The document noted, “dec_4” but sample data (also the published paper) was given “4-Dec” which is a date format. It returns an error if I use “dec_4” but “4-Dec” doe not make sense.

Could you clarify or modify them?

Hi @urgendalai , very glad to hear that the model ran successfully!
Thanks for pointing out these inconsistencies in the model documentation and sample data, I can understand how these could be confusing. The important point, which you can find on p 10 and 11 of the model documentation, is that the PFT fractional cover path pattern must match the filename of your PFT rasters. So, if the file name of your PFT raster contains a space, then the PFT fractional cover path pattern must also contain a space. I’m glad you got this figured out!

You also figured out the dec_4 parameter, which is annoyingly automatically converted to date format if the csv file is opened with MS Excel. Looks like you are all set for now.

Hi @GingerK, I have the same problem of PFT fractional cover path pattern, my pft raster was named pft1
Rangeland-Production-Model-log-2022-02-26–14_53_38.txt (121.7 KB)

Hi Said, maybe try this. If your tif file is formatted as pft 1.tif, then in the input window,
you type pft <PFT.tif. (The post eliminates <> marks so I have to delete one of them to keep text here.)
Make sure they both have a space between pft and number.

My was like this,


hi @urgendalai , i try this and doesn’t work

I am not sure what the issue is exactly but just a small note, make sure using all " / "

1 Like

hi @urgendalai, can you till me how you get the ‘pft’ raster, and the prop legume please

Hi @Said , I created both pft and legume rasters, given there is no data available to my case and they are just indexes for linking data to calculations.

I think this is a good reference for pft,

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.