Coastal vulnerability 3.8 - model run stuck on creating shore points along edge of landmass

Hi,

I am new to this tool, I am currently running the coastal vulnerability model version 3.8.
The model appears to be running fine until it gets to “creating shore points along edge of landmass”. It has been showing that message for 3 hours with no change, and the same thing happened last time I ran it. ;The data and workspace are stored in an external drive.
I am trying to calculate the vulnerability in the UK coastline, I am wondering if this issue has to do with the large scale? Is it common for the model to take such a long time to process? Since it’s the first time I’m using it, my concern is that there are other issues that I am not aware of that prevent the model from running smoothly.
I am attaching the run log and would appreciate your advice.

Thanks a lot!
Shachar

InVEST-Coastal-Vulnerability-log-2020-03-27–12_47_21.txt (3.9 KB)

Good question. In my experience it should never take this long for the model to complete these steps. The first thing I would try is moving your workspace to a local drive (at least the output workspace, if not the input data). Invest models tend to do a lot of reading/writing to disk and if your external drive is accessed over a network, this would slow things down dramatically.

Let us know if that helps!

Hello Dave,

I moved to workspace to a local drive and specified the AOI in order to speed up the calculation. It seemed to help, but
now I received multiple errors. Please find the attached log.

Thanks

Shachar

image001.jpg

InVEST-Coastal-Vulnerability-log-2020-03-28–10_41_26.txt (6.53 KB)

Okay, great, that did seem to help. This new error is puzzling because it suggests the WaveWatchIII input data is corrupt somehow, but it looks like you’re using the sample data for this, which has been used many times before.

Is it possible for you to move the input data to your local drive as well? If that does not help, would you share your AOI so that I can try to reproduce the problem?