Coastal Vulnerability Model - ArcGIS gpkg add data error

Hello. I have run the InVEST coastal vulnerability model successfully a few times now, but my most recent run is having issues loading gpkg (the SQLite Database Feature Class) into ArcGIS Pro. I keep getting an add data error in ArcGIS that says “Exception from HRESULT: 0x80041594”. Other file types are loading into ArcGIS, such as the intermediate tif and shp files. I have tried googling and searching this platform but can’t seem to get to the bottom of this. I’m using ArcGIS Pro 2.8.2 and coastal vulnerability model of InVEST 3.9.0. Thanks. InVEST-Coastal-Vulnerability-log-2021-09-10–16_27_02.txt (435.7 KB)

Hi there, thanks for posting. I haven’t seen this specific error before, but I have heard of issues with gpkg in ArcGIS. This thread offers some ideas of things that might cause this problem. Coastal Vulnerability: csv output looks good - gpkg output does not open in ArcGIS

Which file in particular were you trying to open? Or does this error occur for any of the gpkg files that the model created? Can you share one of the problematic gpkg files by uploading it here? Or by sharing a link?


Thanks for responding so promptly! I am not able to open any of the gpkg files in ArcGIS. I tried in QGIS too (as suggested in the thread you sent) but did not have luck. The coastal exposure gpkg is in the dropbox below.

To provide some background, the difference I did between this run and previous runs was to clean up my coordinate systems for my local data (not for the provided global data like WW3). I know InVEST will convert projections as needed, but I was trying to do best practice by getting onto same projection. It helped immensely with my fetch / wind warnings (I don’t have them anymore!) but I can’t open the gpkg files for some reason. Thank you.

Hey @N01467244 -

I couldn’t open your gpkg in ArcGIS either, so tried to look at it in ArcCatalog, which gave the error “The coordinate system description is invalid”. It would be nice if ArcGIS actually told you this when trying to bring it into a session! So you might want to re-check your coordinate systems, and look through the model log file to see if there are any related errors or warnings.

~ Stacie

Thanks for sharing your data. The gpkg opened fine for me with QGIS v3.10. I assume you were able to load your original AOI in ArcGIS? All output data should end up with the same coordinate system as the AOI, so it’s strange that ArcGIS can’t interpret it.

Interesting, good to know. Yes, I created my AOI in ArcGIS. My AOI (and most of my data) was in Albers Conical Equal Area [Florida Geographic Data Library] projection, since all of my habitat data was in that projection… maybe I’ll try a UTM projection for my AOI instead. If that doesn’t work I’ll just use QGIS. Thanks for your assistance!

Yes, UTM systems are a reliable choice. Though if you don’t want to re-run the model (I noticed it’s a long one) you could probably use QGIS or other tools to transform the geopackages to another coordinate system (and/or file format) and then presumably they would be readable in Arc?

Good idea, thanks for your help!