DelineateIt how to make outlet features?

Hallo everyone,

I started using the InVEST recently, and now I have a probrem with make outlet features.
I tried to make outlet features using line data (river) on ArcGIS, but I don’t know how to do.

How should I do to make outket features? Any idea would be great.

Thank you.


Hi @yuni -

DelineateIt is currently made for creating watersheds that flow to particular points on a stream, for example drinking water facilities, hydropower plants or towns. So we often have existing spatial data showing the point location of those places, and these points are the outlets for DelineateIt. If you do not have existing points, you can create them manually. For example, you could create a new point vector layer (like a shapefile) and use a basemap to visually locate the location of a dam, and add that location as a new point in your vector layer. Then that point vector layer would be the outlet input to DelineateIt.

Hopefully that helps, but if not, please describe in more detail what you need to do and I can offer other suggestions.

~ Stacie

This is a useful summary. Thank you @swolny.

I have made a vector later shapefile for a dam. However, it is unconnected to the catchment of interest. When I generate an output from the DEM and this shapefile, the only result is the same DEM with a border.

Not sure what kinds of outputs should be coming out? There is no delineation of the catchments unfortunately.

Kind regards.

Hi @ndmetherall -

The User Guide provides a listing of the outputs that should be created.
Do you see watersheds.gpkg? Did any errors occur when running DelineateIt? It may be useful to see the log file (.txt) produced, if you can post it here.

~ Stacie


Dear @swolny

Thanks for the response and advice. I have copied and pasted the log file as advised: (upload://kdv3bk8aJFr0AwzeGfdUA71rTuz.txt) (7.1 KB) InVEST-DelineateIt-Watershed-Delineation-log-2021-01-11–09_14_42.txt (7.1 KB)

I did not see any errors. When I try to open the .gpkg file there does not seem to be a result.

For the outlet features input, I have only used a vector of the river shape that I am most interested in. The island has no lakes but some reservoirs. However, none of these connect to the river I am interested in.

Any further advice would be appreciated.
Best wishes.

Hi @ndmetherall,
Thanks for sharing your log file. There are a few suspicious lines:

INFO Checking 1 geometries from source vector
WARNING Feature 0 does not intersect the DEM. Skipping.
INFO 0 features copied to preprocessed_geometries_delineated.gpkg from the original 1 features

It is skipping the calculation because the one feature in your outlet features input does not overlap with the DEM map at all. If you open them both in your GIS software, do they appear to overlap?
If that doesn’t seem to be the problem, please share your data and I’ll look into it. You can upload it here or email it to me privately:

1 Like

Hi @ndmetherall -

You’ve said that “I have made a vector later shapefile for a dam. However, it is unconnected to the catchment of interest.” and “For the outlet features input, I have only used a vector of the river shape that I am most interested in. The island has no lakes but some reservoirs. However, none of these connect to the river I am interested in.” Do these mean that you are providing an outlet feature that is not actually located within the area covered by the DEM? If this is the case, then of course DelineateIt cannot create a catchment, since it uses the DEM to create the watershed that flows to the point of interest. (And actually, I’m not sure how DelineateIt handles linear features - does anyone else know? I know it takes points successfully).

Or perhaps I’m misunderstanding, and @esoth will figure out what’s going on.

~ Stacie

1 Like

DelineateIt will happily take any features of any geometric type and delineate a watershed from that feature. So a river represented by a linestring is no problem at all … 1 watershed will be delineated for each feature. so if your river network is divided by Strahler stream order or something, you’ll get 1 watershed for each feature. If you river has only geometric 1 feature, then you’ll get 1 watershed from DelineateIt.

1 Like

Interesting @jdouglass, and very cool! Let’s add that information to the User Guide.

~ Stacie

Just added a note to the DelineateIt UG chapter about the geometry type of the outlet features to hopefully clarify this.

1 Like

Wow, thank you @swolny @esoth - was not expecting so many responses. Thank you all for your advice.

I tried attaching the DEM and the vector shapefiles. To answer your questions, these do overlap. Have not had luck uploading on this forum (perhaps due to file size of the raster) so will try to email to

Perhaps there has been an issue with the projection CRS? Or something along these lines? Çould this affect the results?

Thanks again.

Thank you also, @jdouglass and @swolny for these insights

Thank you for your advice in using the DelineatIt software.

I am attaching the files to hopefully help in this process including:

  1. DEM of Viti Levu including a sink-filled version (main island of Fiji)
  2. Vector shapefile of Ba River Catchment (outlet file within study area)

Files are saved here in google drive folder:

Note, these files should overlap as the river should fall within the island of Viti Levu shown in the DEM.

Any further advice or info will be much appreciated. Thanks again.

Best wishes.

1 Like

Hi @ndmetherall,
I was able to reproduce the problem and that is very peculiar. I’m looking into it and will have an update for you soon!

1 Like

Hi again @ndmetherall,
This is turning into quite a puzzle. In the meantime, I suggest you try reprojecting your DEM into the same projection as your outlet features, that may fix the problem.

Thanks for this advice. Will try again. Could I also ask if it would make any difference whether we download our SRTM / DEM data from the NASA platform in the course materials or from Earth Engine or should the results be the same regardless?

I tried again recently with the NASA SRTM DEM but it doesn’t seem to be able to recognise the data as being in the suitable format with linear units. Any advice about how to put it into linear units? I have tried multiple projections that are usually suited for linear units.

It worked a bit better with the Earth Engine DEM but this still resulted in the original problem you have been able to replicate.

Thanks again for all the work on this.

Kind regards.

Hi @ndmetherall,

So long as the data meet the criteria needed for use in InVEST, where the data come from shouldn’t make a difference in how the model is running.

Using a UTM projection (looks like maybe zone 60s would be best for Fiji?) should work well except for Web Mercator. As for reprojecting itself, Stacie has a great post on another thread (How to deal with the error message "Dataset must be projected in linear units."? - #2 by swolny) that you might find useful as well.

Please let us know how this goes!

1 Like

This was all very useful and I managed to reproject (warping the DEM and exporting the vector in UTM 60s CRS).

My DEM includes the entire Northwest portion of the island including the watershed here: Screen Shot 2021-01-21 at 8.34.46 am
The Vector outlet file includes a digitized polygon of the river of the study area here:
Screen Shot 2021-01-21 at 8.35.05 am

I have tried to rerun the model with mixed results.

  1. When I skip invalid geometries, I am able to yield new flow direction and filled dem rasters which seem to be correct. However, I am not sure if I am also supposed to generate a vector with the boundaries of each basin? These are the output files, when I try to connect the .gpkg files they seem to just load as empty attribute tables without any xy visualisation.

    Screen Shot 2021-01-21 at 8.28.18 am

  2. When I do not skip invalid geometries I get the message: “The geometry at feature 0 is invalid…” Screen Shot 2021-01-21 at 8.28.45 am

I have included the log.text here as well for further investigation. I notice the text saying: “INFO Too few points in geometry component at or near point 571407.62567608478 8061008.7271340564” - I’m not sure if this is the source of the issue or how to fix this?
InVEST-DelineateIt-Watershed-Delineation-log-2021-01-21–08_00_45.txt (2.5 KB)

Any further advice or info is much appreciated.

Well, that’s an error I haven’t seen before! Clearly there’s some sort of geometry problem with the feature, but I’m not familiar with what, specifically, would cause that error.

I see from your logfile (thanks for including that, BTW!) that you’re running InVEST 3.8.9. Could you try downloading and installing InVEST 3.9.0 and see if this issue persists?

If that doesn’t work, could you send your inputs to so I can take a closer look?