Habitat Quality Permission Error Encountered

Hi, i am facing an error while running Invest Habitat Quality Module. While running the model, the message is “Permission Error Encountered” (screenshot attached). I am also attaching folder containing inputs Please guide me. I shall be very thankful to you.

New Compressed (zipped) Folder.zip (83.8 KB)

Hi @shahzad,

Thanks for the inputs. It looks like the PermissionError is on the logfile, could you see if a logfile txt was generated at all in the workspace?

A few other questions that would be helpful:

  • What version of InVEST are you running?
  • Do you have write access to C:\\Users\\Shahzad\\Desktop\\HQ Maps\\InVEST\\? Can you manually create a file in this directory?



Thanks @dcdenu4 thanks for your kind response. logfile. txt was not created at all.

  1. i am using InVEST Version 3.9.
  2. Yes i have write access to C:\\Users\\Shahzad\\Desktop\\HQ Maps\\InVEST\\ . i can manually creat a file in this directory

Hi @shahzad ,

That is pretty strange. Some more questions:

  • When you run the model there should be a black terminal window in the background, could you post what is in there when this run fails?
  • What version of Windows are you running?
  • Have you used a prior InVEST version before with any issues?


I have also experienced this error with the carbon model - InVEST 3.9.0, Windows 10. I solved it at the time by setting my workspace for the model to be directly on the C drive (e.g., “C:\workspace” instead of “C:\Users\user\workspace”).

But the issue is inconsistent and I haven’t figured out yet what exactly the conditions are that cause the issue to crop up. I’ll post more here if I can reproduce it consistently!

I have not experienced this issue with the Habitat Quality Model (HQM) previoulsy but I did experience it with the Carbon Model several months later. The only two changes that could have contributed the error:

-I updated from InVEST 3.7 to 3.9

  • I adjusted my Win10 PC Account User Name without succesfully changing the account name on the C:\Users folder.

  • I tried resolving this by reinstalling InVEST and it failed
    -I then renamed my user account back to the original name and it also failed.
    -I tried moving the workspace inside and outside the data sets folder and it also failed no matter the combination.

I finally succeded running the Carbon Model after assigning the workspace directely to the C -drive. Thank you Ginger!

C:\Carbon Model Workspace

I attempted to run the HQM to see if I would have the same path recognition issue today. HQM will not recognize the threat rasters that I previolsy succefully selceted a path to. I tried multiple data sets and it still won’t let me execute run. It seems there is a larger issue at play.

1 Like

Hi @daveadema , I’m glad you were able to get the model UI to open, at least! Could you attach your threats table to this thread so we can take a look? Often times it’s an easy enough fix.