Habitat Risk Assessment Simple Error?

Hello all,

I am a new user for the Habitat Risk Assessment model version 3.6. I am on the final step of the Habitat Risk Assessment GUI. When I run the model I receive this error message:

" [Error 3] The system cannot find the path specified: u’C:\Users\** gverutes \Downloads\Bycatch\gis\Johor_SRA\Species\_FINAL\.'

I believe this message is referring to when I ran this model back in January with Greg Verutes, yet none of my file paths point to his data.

To troubleshoot this issue I have already tried…

  • clearing my cache multiple times
  • uninstalling and re-installing the InVEST tools
  • Triple checked my file paths are going to my files and workspace

I am hoping this is a simple issue that I have been blind-sided by…

Thank you,

Hi there, thanks for posting. This is a strange one! It will help if you can upload the full logfile (.txt) from your run.

In this model there are some places besides just the GUI where file paths are specified (a ‘dir_names.txt’ file in the criteria scores folder, I think), so it is worth looking there as well.

Lastly, the HRA model was recently upgraded to streamline the user-interface, so I encourage you try InVEST 3.7.0. I can almost guarantee that will avoid this particular error, though it will require a small bit of re-organizing of your input data. That in itself though, may solve this problem.

Hi Dave,

Thank you for the reply. Yes, you are correct! I did not update the dir.txt file. (I knew it was going to be a simple mistake). I will try using the updated 3.7 InVEST model… As I am getting other errors after fixing this one.

Thanks for the help. I may be back for more :slight_smile:

1 Like