HRA_ValueError: file does not exist

A student of mine did a previous run on HRA with a set of habitat layers and stressor layers, which worked fine, but now she added more stressors (to the stressor layer folder and in the CSV files) and in the new run there was an error indicating that the first of the habitat files did not exist in the habitat folder.

I tried creating new files and double-checked the names, but can’t seem to understand why the model isn’t seeing the habitat file.

I also couldn’t find any similar error reported here in the forum.
Any ideas?

InVEST-natcap.invest.hra-log-2022-08-11–17_42_18.txt (2.5 KB)

Using InVEST 3.11 with new workbench

Hi @carlaelliff ,

Is it possible that the file mentioned in the CSV is missing its file extension? The file C:\Users\carla\OneDrive\Documentos\InVEST\HRA_model\test11.8\habitat_layers/area_praial looks fine to me except for the file extension (which might be hidden by default on Windows)

Another possibility: is area_praial a folder containing files for a multipart file such as an ESRI Binary Grid or an ESRI Shapefile? If so, be sure to select one of the files within the directory, like hdr.adf for a Binary Grid or the .shp file for an ESRI Shapefile.

If neither of these end up being the case, let me know!

1 Like

hi @jdouglass !
I forwarded your answer to her and she managed to fix the problem!

Thanks! :))


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.