InVEST 3.7.0. HRA model and criteria table errors

I am having problems with the criteria table. Errors, which I believe are formatting, occur when I run the model. The errors are:
ZeroDivisionError: float division by zero;
ValueError: The Criteria table is missing the column header “CRITERIA TYPE”;
ParserError: Error tokenizing data.

The errors presented change as I try to introduce different formats for the table (.csv and .xls files). I can only run the data that comes from the model itself, with the format of the criteria frame that comes with the system (.csv and with all the information in one column and separated by commas). With my own data I can not.

Thank you so much for your support!

Hi there, thanks for posting.

Please upload your logfile from the output workspace and the input CSV that is causing the failure and I’ll take a look.

1 Like

Hi, There!

After posting the message I was able to get my data processed by the model. However, when I try to open the preview files on the site, nothing appears. Not even the map information from the site itself …
What may be happening?
All my geographic data is in .shp format, and I didn’t use any spatially explicit criteria …

Thanks for your attention once again!

InVEST-Habitat-Risk-Assessment-log-2019-10-16–13_42_46.txt (152.0 KB) Habitat_Stressor_Info.csv (1.0 KB) (10.3 KB)

Okay glad you solved the formatting issue.

Are you saying that the webmap at is not loading your data? It seems to be working okay on sample data.

Can you look at your output data in GIS? Do things appear normal? I’m a little concerned by all the errors in the log saying latitude or longitude exceeded limits. Also this: Target projection from AOI: Transverse_Mercator. EPSG: None. I would expect EPSG to have a valid code. What is the coordinate system of your AOI?

If you can’t figure it out, feel free to share your input geographic data and/or your output workspace. (a link to google drive, dropbox, etc might be necessary for large zip files).

1 Like

Hello! I solved the problem! My shape data was with geographic datum, not projected. But anyway, thanks so much for the help!