Seasonal Water model run error - not running

The Seasonal Water model was working OK on my computer until a few days ago, now it will not. A re-install of the software has not helped.Tried several things with no success. Any suggestions? Anything similar currently being observed by any other users ? (log error message copied below)

Thanks !


2 attempts model error messages from log files are:

attempt 1:

2021-01-24 13:09:15,719 seasonal_water_yield._execute(392) INFO prepare and test inputs for common errors
2021-01-24 13:09:15,766 model._logged_target(1652) ERROR Exception while executing <function execute at 0x0000023147272C18>
Traceback (most recent call last):
File “site-packages\natcap\invest\ui\”, line 1649, in _logged_target
File “site-packages\natcap\invest\seasonal_water_yield\”, line 377, in execute
File “site-packages\natcap\invest\seasonal_water_yield\”, line 402, in _execute
File “site-packages\natcap\invest\”, line 541, in build_lookup_from_csv
File “site-packages\pandas\core\”, line 1470, in to_dict
UserWarning: DataFrame columns are not unique, some columns will be omitted.
2021-01-24 13:09:15,766 model._logged_target(1655) INFO Execution finished
2021-01-24 13:09:15,766 utils.prepare_workspace(129) INFO Elapsed time: 0.05s

attempt 2:

01/24/2021 13:34:27 natcap.invest.seasonal_water_yield.seasonal_water_yield INFO prepare and test inputs for common errors
01/24/2021 13:34:27 natcap.invest.ui.model ERROR Exception while executing <function execute at 0x139950F0>
Traceback (most recent call last):
File “C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\ui\”, line 1579, in _logged_target
File “C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\seasonal_water_yield\”, line 162, in execute
File “C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\seasonal_water_yield\”, line 184, in _execute
File “C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\”, line 451, in build_lookup_from_csv
UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
01/24/2021 13:34:27 natcap.invest.ui.model INFO Execution finished
01/24/2021 13:34:27 natcap.invest.utils INFO Elapsed time: 0.55s

Hi @BVIB ,

Thanks for posting. Could you attach the log text file here that is created in the workspace when you run a model?

Which version of InVEST are you using?



I’m also wondering what changed a few days ago. And what is different about the two runs that you posted errors from? Are you using any different data inputs? If so, what about these new inputs is different than the ones that did not give errors? Have you done a comparison? The model’s behavior should not change if you’re using the same InVEST version and the data inputs haven’t changed.

~ Stacie

1 Like

Thanks Stacie and Doug for your replies. You are correct. There have been too many data input file changes at my end for you to be very diagnostic at a distance. Also…could be memory & file size issues locally on my computer perhaps because I am using a dense large-ish data set (approx 260 km sq data set; at 1-m resolution DEM X 10-m resolution LULC) …resulting model runs relatively slow to run to completion and output files large. (although Annual Water, SDR & NDR all work OK with same data sets).

Let me work at it for a bit… if I can see something more specific, I’ll ask again.Thanks.

Gordon, in New Brunswick

I found my problem here I believe. One of my .csv format input data files was probably damaged or partially corrupted (or something ). The csv file still opened visibly OK in Excel, but the file did not read into or work OK in InVest.

The InVest model problems went away once I replaced that .csv data input file with another csv data input file. Thanks again.

1 Like

Hi @BVIB ,

Glad you worked out the problem! We certainly have struggled with Excel covering up problems with input data. We usually like to open CSV files and tabular data in a text editor like Notepad or Notepad++ that better shows how the file is actually structured. Maybe that will be useful later on.