Urban Cooling Model_rural application

Hi Stacie - many thanks for getting back to me so promptly. I set up the model again, this time with a raster that I’m sure has no [0] values - if its Attribute Table in ArcGIS is anything to go by - please see attachment. I’ve included the TIF file and log file too. Any idea what I’m doing wrong here?

When I bring this new LULC into ArcGIS, and create a raster attribute table, it now shows that most of the pixels have a value of 0. This time, they are surrounding the 33 and 40 values, so perhaps the 0 values are meant to be NoData?

Let’s see if this screenshot gets embedded in the post:

~ Stacie

Hi Stacie
I reclassified the No Data and 0 classes to ‘33’ (pasture), in this TIF:

But this still generates the same error message from the UC model.
Wondering if you are seeing the same when you bring this into ArcGIS?

@Minton71 This time it looks like the 0s are gone, so your reclass worked. However, it is best to have a NoData value set, since InVEST sometimes has problems if one is not assigned (you can search this forum for examples). And actually, it is possible that this current 0 issue might have to do with not having a NoData value set, so first try setting a NoData value (to some integer that is not a valid LULC code).

If that doesn’t help, please post the log file and data again and I’ll check it out.

~ Stacie

Hi Stacy

Thanks for getting back to me. I started from scratch, new GDB, drew the boundary SHP file, the pasture and clump features, merged these and converted the merged layer to a raster, reclassified values to lucodes, including leaving the NODATA as NODATA – same error resulted. Then, as per your email, I also reclassified NODATA to ‘99’, and had the same error.

Log files and new TIF files saved at:

Many thanks

Richard

Looking at both of the layers you sent in ArcGIS, they both still include the same background 0 values, and neither have a NoData value set. What methods are you using to assign NoData and reclassify?

~ Stacie

Hi Stacie

I’ve been using Reclassify (Spatial Analyst Tools):

In this screenshot you can see the Attributes Table of Reclass_Recl1.tif, one of the rasters I sent you. Although the Attributes show only 33 and 40, I see a green 0 value in the Contents pane. So I Reclassified this raster. The reclassified Raster Reclass_Recl2 appears definitely not to have any 0 values:

I then Export this Raster in able to locate a TIF file (Reclass_Recl2.tif) to upload to InVEST. Still looks OK:

Which I upload to InVEST:

And immediately get the same error (no processing time at all):

Log file and latest TIF at this link:

https://www.dropbox.com/sh/pphwnwrb01rlmv2/AADxsSdUGaQcgqxynxgVOcS6a?dl=0

Many thanks

Richard

Hi Jesse

Continuing on from my initial query about applying the UC model to a rural setting, I would appreciate your feedback regarding some assumptions I am considering regarding the Urban Heat Mitigation Index (Effect of Large Green Spaces).

The setting for my research is a flat expanse of pasture (area = 100 hectares / ~250 acres) which we will populate with clumps of trees. These clumps will be of various sizes and distances apart – my larger research is looking at the correlation of clump configuration with other ES besides cooling. In keeping with the UC model’s adherence to Zardo et al. (2017), asserting 2 ha is the minimum size of green area providing a cooling effect, some clumps will be 2ha or larger.

Our main interest is in calculating the declining cooling effect from a clump of trees, and subsequently, the impact this can have on relieving overheating of livestock in pastures (in addition to shade). Here’s a diagram (plan view at top, section view with Cartesian expression of declining cooling effect below) illustrating our approach:

Based on the UC model’s equation 106, we will determine the form of the declining cooling curve following this logic:

Eq. 106:

Thus:

Applying this to the Cartesian graph above:

I would greatly appreciate any comments you have with regard to taking this approach. It goes without saying that the calculation of CCI for each clump (CCclump) will require experimentation with how we parametrise the Zardo formula (CCI = 0.6x shade + 0.2x albedo + 0.2x ETI).

Many thanks

Richard

Hi Stacie

Is it possible the problem is being caused by the Area of Interest (Vector) data that I’ve been inputting. I have just been inputting a singular SHP file, which I understand ca be meaning less without all the other attendant suffixes (.shp + .shx, .dbf, etc.). If so, what type of file should I be uploading here?

Cheers

Richard

That jives with what I’m seeing, Richard. The one thing I noted previoudly about Reclass_Recl2.tif is that it does not have a NoData value set. When you do Export Raster, try setting a NoData value (to a number not used in your biophysical table) and see if that helps. The “NoData value” entry appears to be blank in your Export Raster panel.

As for the Area of Interest, yes, we need to enter the .shp file into the interface, and the model will automatically find the other related files. This should not be causing the problems with 0 values in the LULC raster.

~ Stacie

Hi Richard,

I’m not the best person to comment on this approach as I’m not so intimately familiar with the model math. @chris or @lons0011 , might you be able to provide feedback here?

Hi Stacie

Thanks for confirming the SHP file grabs the other file types too.

When I reclassify Reclass_Recl2.tif, even though I set NoData to ‘99’, the resulting Reclass_Recl3 raster still shows NoData as NoData:

Value 99 doesn’t seem to have made it through…

Any thoughts?

Richard

In the Reclassify tool, if you set the Value NODATA to 99, those pixels will no longer represent the special NoData/Null value, but will represent a valid value of 99.

What happens if you do this:
1/ Reclassify, only changing the 0 values to whatever they should be (33/40), leaving the NODATA Value unchanged (i.e. with New set to NODATA).
2/ Use Export Raster on the reclassified result, setting the “NoData value” in that tool to 99.

~ Stacie

Hi Stacie

Still the same result unfortunately:

I assume the ‘lulc_UC.tif’ referred to here is picking up the changes being made to the LULC Rasters input: ‘The following 1 raster values [0] from “C:/M1S/220805(UC)\intermediate\lulc_UC.tif”?

Reclass_Recl5.tif (97.1 KB)

What I see is that Reclass_Recl5.tif has two values: 0 and 1, and it does have NoData set to 99, so that’s a step forward.

~ Stacie