Urban Flood Mitigation - Error with Building Vector


I’m trying to run the Urban Flood Risk Mitigation model and I encounter an error with the damage loss valuation. It seems that there is an issue with the buildings vector provided - here is the log file: InVEST-Urban-Flood-Risk-Mitigation-log-2021-11-10–14_24_19.txt (28.1 KB)

I’ve checked against the damage loss table provided and the values in the ‘type’ column are matching: damage_loss_current_unique.csv (22.8 KB)

I managed to run the energy savings valuation for the urban cooling model with a similar buildings vector and it worked fine.

I’m not sure what the issue is here, I would greatly appreciate your help, thank you!

Hi @emsonali , thanks for posting.

The error message suggests there is a feature in the buildings vector with a “type” value of 3038. But there is no corresponding row in the damages table for a type of 3038. So you will either need a new row in the table to list a damage value for a “3038” type building. Or you could edit the buildings vector to assign those buildings a different type.

There are also a couple of errors earlier on in the log that may or may not be causing other issues. If you still encounter errors, could you also share the rest of your input data? Thanks,

Hi @dave, thanks for getting back to me. I actually modified the ‘type’ column several times in both the buildings vector and damage table to no avail. The issue seemed to be with the id column for buildings, in this case ‘fid’, which was causing issues. Eventually what worked was to remove all other columns in the buildings vector except for ‘type’ and to fix the geometries, and the model ran fine thereafter. So all good now, this topic can be closed. Thank you!

That’s interesting. Thanks for following up!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.