Vector layer no corresponding with csv buildings

I have a problem with the Energy savings valuation model. I created a csv table with a “type” field and the same in the vector layer, but the program does not recognize these fields. I include the file with an error, as well as the table. I don’t know what I am doing wrong and why the table does not correspond to the layer, I tried to change the “type” column and the values ​​in it but the same error comes out.

InVEST-Urban-Cooling-Model-log-2021-05-11–21_08_47.txt (9.3 KB)
Tabela do budynków energia.csv (669 Bytes)

Thanks for writing in @Marcin. I’m sorry to hear that you are having difficulties. Please confirm that you are using the Urban Cooling InVEST model.

From your screenshot, it appears that the attribute table for your Buildings Footprints Vector input layer is not constructed properly. Refer to the example provided in the InVEST sample data (download) and organize yours in the same way. The first column should contain a unique ID for each building (often labeled ‘OBJECTID’ in a GIS by default). A separate column labeled ‘type’ should contain the values that correspond to the ‘type’ column in your Energy Consumption Table input CSV. Please see the screenshot below.

I hope this is helpful,