Value Error: Flow accumulation in SDR

Hi All,

I was looking for a similar topic as this one but I cannot find.
Anyone encountered this same error message? And how did you address this?

ValueError: (‘got a %s when trying to read %s at %s’, None, [‘C:/Users/jureta/Desktop/SDR_2018_SCSubBB\intermediate_outputs\flow_accumulation_SCSubBB_K096_2018.tif’], {‘xoff’: 16384, ‘yoff’: 13312, ‘win_xsize’: 256, ‘win_ysize’: 256})

Here’s the log file for reference.
InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2020-03-10–23_43_53.txt (54.4 KB)

Thanks!

Hi @carlureta,

Looks like it could be similar to this NDR issue: NDR: Value Error

We’re still working on debugging that issue at the moment.

Doug

Hi @dcdenu4,

thanks for this.
yes, it seems similar to that one. thanks for routing me that.
maybe something to do with large dataset?
but I did an even larger dataset before (state wide) and it worked fine.
will wait for further updates on this.

many thanks for your help, as always.

Carl

Hi @carlureta,

Just thought I’d send an update here. We are still actively looking into this issue but in the meantime we have seen some success when pre-filling the DEM for sinks or pits. We are doing this using the Fill Sinks (Wang & Liu) tool in the QGIS tooblbox.

Could you try filling the sinks or pits of your DEM and then using that DEM to run the SDR model?

Cheers,

Doug

@dcdenu4, thanks for the update. will try that. The DEM that I use, though, is a filled DEM from ArcGIS. Will try it again with your recommendation and let you know.
Thanks a lot!