ValueError: ('got a %s when trying to read %s at %s' None, / SDR MODEL

Dear developers, dear community,

This issue has being reported in the past in the forum, altough I did not found a definitive answer. I link a similar past issue here -> Value Error: Flow accumulation in SDR
When running the SDR model In found the same problem as in the link ( a value error). I tried what the developers suggested, like using an updated version ( I am using version 3.8.9 now) and filling the sinks in the DEM. However I still get the error.
InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2020-11-06–15_41_53.txt (13.2 KB)
I thought I would refresh this issue in the forum to see if there are recent developments.

best regards,

Well that is a poorly-formatted error! The root cause of the issue here, though, is actually these lines that are a little farther up in the logfile:

2020-11-06 15:50:36,934 utils._log_gdal_errors(72) ERROR [errno 1] LZWDecode:Corrupted LZW table at scanline 2304
2020-11-06 15:50:36,937 utils._log_gdal_errors(72) ERROR [errno 1] TIFFReadEncodedTile() failed.
2020-11-06 15:50:36,939 utils._log_gdal_errors(72) ERROR [errno 1] H:/SIG/Procesos SIG/Invest_sediment_retention/maule/invest_output\intermediate_outputs\flow_accumulation_1.tif, band 1: IReadBlock failed at X offset 9, Y offset 20: TIFFReadEncodedTile() failed.

The root cause of this error has to do with a bug in GDAL, which will be fixed in the next release of InVEST, which should be out in the next couple of weeks. In the meantime, this development build uses the new version of GDAL and also fixes the formatting of the error:

Let us know how this goes!

Hi @jdouglass,

The development version works!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.