Why Does the SDR Model Complete and Produce a TIF File, but Fails to Show the Content in QGIS?

[sdr basic (2).zip - Google Drive]
The above link contains the files I used this time.And I used Threshold Flow Accumulation: 2, Borselli K Parameter: 2, Maximum SDR Value: 1, Borselli IC0 Parameter: 0.5 and Maximum L Value: 122 for the value.
After I input these files into the SDR model, they all display a green check mark, and after running the model, it shows ‘MODEL COMPLETE.’ However, when I input them into QGIS, all the TIFF files open as blank or only have a border. Can you please tell me how I should correct or improve this situation?

Welcome to the forum @Bridgit10 -

That is strange. I tried to run the data you posted, but the watershed shapefile is missing several required files. Along with .shp, a shapefile includes .shx, .dbf and .prj files.

One quick note that the values in soil_erodibility.tif are very large. They should be roughly between 0 and 1, but your raster has values between 2 and 307.

Also, it would be great if you’d post the entire log file (.txt) that the model produces, just in case there’s something in there that could help troubleshoot. Thanks!

~ Stacie

Dear Stacie,

Thank you so much for your reply! Sorry for not replying back as soon as I see this! I am still trying to find out the data to fix the soil erodibility raster. As I fix this, I will reply on it asap!!

Thank you again!


Dear @swolny,

I just put the log file in the same drive! And I fixed the soil erodibility tiff file and the watershed tiff file. However, the issue now is that the layer displayed in QGIS only has a border. I’d like to ask if this is related to the differences in the ‘Threshold Flow Accumulation’ value settings? Or have I missed something, causing the layer to not display correctly?

thank you agian!


Dear Stacie,

I change the drive link into this!!!


Hi @Bridgit10,

I haven’t checked out your data but a Threshold Flow Accumulation of 2 is very low. This value is the number of upslope pixels that must flow into a pixel before classifying it as a stream. So it could be the case that all your pixels are being considered a stream! Try bumping that number up to 200 or more and see if you start noticing a difference. You should see a stream.tif output and you really want that raster to resemble what you’d expect for your watershed.



Hi Doug,

Thank you so much for helping! But I just wonder that the Threshold Flow Accumulation I set was acyually 10000! I try to set it as 200 as you said, but the stream.tif just keep showing as a boundary. I took watershed as a range that I only give one polygon inside, I am not quite sure whether it’s the reason to lead the strange result or not. But the reason I did this is because the watershed just could not like the other range show in the tiff file because it was influenced by the pour point. So I just use the range as the watershed. As in this situation, could I got some recommendation to fix the problem?

Thank you!



Hi Bridgit -

Thanks for posting your data. The problem is that your watershed input is a line feature, but the model requires that it be a polygon. The model clips your input data to the area enclosed by the watershed, but since your watershed is a line, it’s only clipping out a thin line around the border, rather than the whole polygon. Try converting your watershed to a polygon and see the difference.

~ Stacie


Dear Stacie,

Thank you sooooo much!!! I just tried to change my watershed into polygon and I finally got the result!!

Thank you again!!!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.