Carbon: modelling works, but results are incorrect (only underground biomass)

Hi everyone,

I need your help to solve a problem for which I can’t find the solution. I’ve searched the forum, but haven’t found an answer.

This is the second time I’ve worked with this model and the first time I’ve encountered this problem. I entered my LULC (2020) and attached my carbon tank table (csv format). When I press “Run”, everything works. But it’s when I display the results on ArcGIS Pro that I see there’s been a problem with the calculation. It seems that only the underground biomass reservoir was taken into account in the modelling: the results range from 0.49 to 1.89 tc/ha, even though it’s a forest massif… my hypothesis is that the other reservoirs were not taken into account.

Do you have a solution or have you already encountered this problem? If so, how did you solve it?

I’ve also tried changing my C values in the reservoir table to “number” format instead of “standard” (csv file), but to nothing effect.

Thanks in adavnce for your help,


Hi Laurie -

I have not seen this issue before. Can you send me your input data and I’ll take a look at it? Here are instructions for creating a datastack. If it’s too large to attach here (or you would rather not attach it here), you can provide it via Dropbox, Google Drive or whatever you use.

~ Stacie

Hi Stacie,
Here you are: (2.4 MB)

Maybe I missed a step or made a mistake, either when producing the lulc rasters or the csv file? I’ve tried a few things, thinking that would solve the problem, but I can’t see what I’ve missed. It’s just the result that surprises me, normally we should have much higher values of Tc/ha.

Thanks again your help,


Thanks for sending your inputs. The results look fine to me. Remember that the result values are given in tons per pixel, not per hectare, and in your case pixels are 10x10 meters, so it’s a small area.

You can sanity check the results by comparing tot_c_cur.tif with the 4 carbon pool mappings that are in the intermediate Workspace folder. Click on a pixel and add them up and I think you’ll find that the total values are correct.

~ Stacie