Coastal Blue Carbon Model error: NoneType object has no attribute Flatten

blue-carbon
#1

Hi James,

I’m trying to run some new layers in the preprocessor for the Coastal Blue Carbon model, and I’m getting an error when I include this one habitat raster of my start year, 2020 (attached), with other rasters for future years. I’ve tried dropping it from the analysis and only running the preprocessor with future years, and that seems to work fine, so I think there’s something about this raster that’s causing trouble. It also doesn’t seem to matter what future rasters I include with this start raster. It still leads to the same error.

The error message I get says “NoneType object has no attribute Flatten”
InVEST-Coastal-Blue-Carbon-Preprocessor-log-2019-04-21–20_32_04.txt (2.8 KB)
BlueChab_2020_16bit.zip (97.8 KB)

#2

Hi Monica,

This was an interesting one, and absolutely a bug in the model! Could you try this development build and make sure that it’s doing what we’d expect? Thanks!

https://storage.googleapis.com/natcap-dev-build-artifacts/invest/jdouglass/3.6.0.post492+hf4708a2cf529/InVEST_jdouglass3.6.0.post492+hf4708a2cf529_x86_Setup.exe

James

#3

Hi James,

The preprocessor seems to be handling this raster and the others properly now. The preprocessor completes successfully. Thanks!

#4

Great to hear, Monica! I’ll make sure this fix gets into the next InVEST release.

#5

Starting today my anti-virus software, Sentinal One, decided that the custom builds of the InVEST coastal blue carbon model were a threat shortly after I began a model run. This applies to the build linked above and the other new build of the coastal blue carbon model, InVEST_3.6.0.post493+hffefd28cb7a1_x86

I tried to restart InVEST, but selecting it from the start menu gives me the message “Windows is searching for invest.exe”. This applies to all InVEST modules that came with that build. Regular InVEST 3.6.0 is still working fine. I have not had this problem on any other computers that I’ve put these two builds on so far, but I will try it out tomorrow.

Do you have any advice on how to convince my anti-virus software that InVEST is not malware? It’s not even letting me open the custom build versions anymore.

#6

Hi Monica,

I’m sorry that Sentinel One has decided that InVEST is malware … it’s not the first time this has happened with antivirus software (we’ve seen this before with Norton and McAfee). Until we figure out a more permanent solution, could you check to see if Sentinel One has an application whitelist? If so, is it possible to add invest.exe to it?

Hopefully this will be possible in Sentinel One, and sorry for the inconvenience!
James