Coastal Vulnerability Index error in Bathymetry

Hi all, I have downloaded the bathymetry data from GEBCO and gave as input in Invest. All the data is in acceptable format, when I start to run the model, I encounter an error ValueError: Could not open D:/NIVEDHA/PhD/Data/CVI/Pseudo run\intermediate\wind_wave\gebco_2020_n12.0_s10.0_w78.0_e82.0_clipped.tif as a gdal.OF_RASTER
Kindly let me know how to resolve it

Hi @Nivedha1994,

Could you try renaming that file path so that the periods . are replaced with underscores or dashes? Something like:


Let us know if that helps.


Hi @dcdenu4 Thank you for your input, but the error still persists.

Hi @Nivedha1994 ,

Could you attach your logfile from the model run? Thanks!


Hi Doug,

I have attached the log file. Thank you

InVEST-Coastal-Vulnerability-log-2021-03-03–13_22_30.txt (5.4 KB)

Hi @Nivedha1994 , that’s interesting. I’ve never seen this error before, but it’s clear from the log the problem is: File too large regarding tile size. This would result in a file with tile arrays larger than 2GB

Can you provide some details about the bathymetry raster? What is the pixel size, coordinate system, and the number of pixels (width & height)?

I also noticed the model resolution is set to 1. The units there are meters, so that’s a very high resolution. That makes sense if the rest of the input data are also of a similar resolution and the AOI is fairly small in extent. Otherwise I generally recommend starting with a much larger model resolution (e.g. 1000 - 10000) and making sure the model runs to completion, then adjust the resolution smaller as necessary.

Hi @dave , Thank you for your reply. I have checked on the data. I have downloaded the data from GEBCO 2020 grid which has a resolution of 15-arc second (450m).The area of my study region is 3703 (Sq.kms)

I have tried changing the resolution, a new error has appeared (Typo error: String not found) . I have attached the log file for your reference.
InVEST-Coastal-Vulnerability-log-2021-03-05–14_29_24.txt (4.2 KB)

Hi @Nivedha1994 , that GEBCO data sounds reasonable.

Thanks for posting the new log. It looks like one of the inputs might have a strange projection definition. It’s hard to say which one, but I notice that a few of the inputs changed since your previous log. So probably one of those new layers has an invalid coordinate system definition. If you can’t figure it out, feel free to share those datasets with me (google drive, dropbox, etc) and I can take a look.

Update: I get that exact same error if one of the input datasets is completely missing any projection information.

Hi @dave
Thank you for the update, I will check on the projection.
I have uploaded the datasets in the google drive and have shared the link with you.

Hi @dave I have an update, I tried to identify the projection units of each layer, projected the layers to linear units, now (Typo error: String not found) has gone.

ValueError: Could not open D:/NIVEDHA/PhD/Data/March 5 CVI\intermediate\wind_wave\Bathymetry_clipped.tif as a gdal.OF_RASTER

error has again appeared. Kindly help me with this. I have attached the new log.InVEST-Coastal-Vulnerability-log-2021-03-09–13_36_30.txt (5.7 KB)

Okay, @Nivedha1994 , thanks for the update. I think I’ll need to look at that bathymetry input to figure this out. I just requested access to that google drive link, so you probably got an email? Is the bathymetry raster in there?