Error - Annual Water Yield InVEST 3.6.0

#1

Hello,

I’m receiving an error during the run of an Annual Water Yield model. The main message is “Error: new-line character seen in unquoted field - do you need to open the file in universal-newline mode?”. What is this error about? I think that the information is well prepared, but it seems that the run is interrupted at the beginning.

Attached you can find the log file.

Thank you in advance for the help!

InVEST-Hydropower-Water-Yield-log-2019-05-02–12_00_06.txt (3.9 KB)

#2

Hi @dierestrepo -

My guess is that the error is related to something in the biophysical table. Look at it in a text editor (not Excel) and make sure that the fields are separated by commas (not semicolons), that there are no blank lines at the end of the file, and that all of the data in the fields looks ok. It might be that you have a newline in one of the fields (maybe an LULC description field), which you can see by having the editor show newline/tab/etc characters.

~ Stacie

#3

Hi Stacie,

Thank you for your quick response. I used a text editor and fixed the blank lines at the end of the file, I also found some other small mistakes that could be part of the problem, but it didn’t work, I still receive the same error.

Attached you can find the biophysical table, I think it is ok, maybe the problem is something else.

Thank you again!

biophysical_table.csv (2.3 KB)

#4

Hi @dierestrepo, it looks like the ‘description’ field is missing quotation marks around the text in each row, leading to a parsing error. Could you try the attached table and make sure it works for you?

Thanks,
James

biophysical_table.csv (2.4 KB)

#5

Hi James,

I tried again using your table but it didn’t work. Attached you can find the log file.

I’m starting to think that maybe the problem is not related to the biophysical table. Do you have any other idea?

Thank you very much for your help!!

Diego

InVEST-Seasonal-Water-Yield-log-2019-05-03–14_36_33.txt (32.6 KB)

#6

Hi Diego,

The error in this latest logfile is a different one than the table-related one up above. We’ve recently made some updates to the Seasonal Water Yield model that haven’t been released yet, and it’s very possible that we might have already fixed this. Could you try this development build and let us know if you’re still getting this error?

Here’s the download link: https://storage.googleapis.com/releases.naturalcapitalproject.org/invest/3.6.0.post515%2Bh58c1a96ad82e/InVEST_3.6.0.post515%2Bh58c1a96ad82e_x86_Setup.exe

Thanks,
James

#7

Hi James,

I’m sorry I made a mistake, I sent you the log file of a Seasonal Water Yield model instead of the Annual Water Yield model, that was the one I was trying to fix the problem. I tried again with the biophysical table you sent to me and it worked! so the problem was related to that.

And the error related to the other log file (the mistaken one) was fixed with the other version of InVEST that you sent to me in the last message.

Thank you very much for your help, it was very useful!!

Diego