Error in HQ model

I am receiving an error on my habitat quality model. it is giving me a value error that could not covert string to float. I used the demostration dataset and I have no idea how to solve this problem. I have attached the screenshot of the error and thank you so much for your assistance.

Hi @zouxiaohan -

Would you please post the whole log file (.txt file) that the model produces? That gives us more information that might help - thanks!

~ Stacie

Thanks for you reply, here is the whole log file and I tried many times, the same problem came up every time which makes me frustrated. Hope you can help me figure it out.
Thanks again.InVEST-Habitat-Quality-log-2019-06-11–07_16_52.txt (15.5 KB)

Interesting that you’re having this error with the sample data - I just ran HQ with the sample data and it ran fine. Did you make any changes to the sample data? Specifically, the model is giving an error when processing the threat “lrds_c”, it seems to have a problem with the Threat table entry for “lrds”. Is it possible that the MAX_DIST or WEIGHT values got changed to a string value? Or, sometimes the model gives an error if there is a blank line saved at the end of the table, which might happen if it’s edited and saved in Excel. Look at threats_samp.csv in a text editor, and if there’s a blank line at the end, delete it, save the table and try running the model again.

~ Stacie

Thank you for your advice. I might changed the sensitivity table unintentionally and I re-downloaded the sample data from the website and run the HQ model again. I worked well with the demostration dataset.
So I run the model with my own dataset, it worked successfully and the quality map and deg_sum map came out as a result, however I felt the results were not quite correct, as shown in the following picture, the range of degratdation was not from 0 to 1. Do you know what the problem is?
Thank you again!