Error SWY ET0 input

What is the issue or question you have?

When running SWY the following error appears: File “natcap\invest\seasonal_water_yield\seasonal_water_yield.py”, line 671, in execute
ValueError: No et0 found for month 1.
How do I fix this error?
Et0 has a 30 x 30m pixel.
Thanks
Please clarify.

Maria Rita Fonseca
Brasilia, Brazil

What do you expect to happen?

What have you tried so far?

Attach the logfile here:

Hi @MariaRita -

Have you tried searching this forum for that error? Did the responses help? If not, please let us know what you tried.

~ Stacie

Hi @swolny
There is no answer to my question on the forum.
And where can I find the ET0 data in WorlClim?

Thanks.

Hi @MariaRita -

It sounds like you have existing ET0 data that you are trying to use in the model, but are getting that ValueError. Have you confirmed that the ET0 file names are as required? The User Guide provides specific guidance for file naming and what is allowed (and not allowed) in the ET0 folder.

WorldClim does not include ET0 data. You could use an equation to calculate ET0 from WorldClim, or use CGIAR’s ET0 data, which is derived from WorldClim, and is linked to in the Data Sources section of the User Guide. This section also gives an example of calculating ET0 from precipitation data.

~ Stacie

Hi @swolny ,

The model ran well.
Thanks.
Rita