Habitat quality grid calculator

May I ask how to solve this problem:ValueError: The following land cover codes were found in your landcover rasters but not in your sensitivity table. Check your sensitivity table to see if they are missing: 0.

I heard that you can use the grid calculator to remove 0 in arcgis, but after I did it, the problem in the picture still appeared. Could someone please teach me how to do it?

Hi @SMZ,

Thanks for using InVEST and posting here. I’m curious if you actually want to remove 0 from the land cover raster or if you want to set it to nodata? If 0 is not a valid land cover code then I recommend setting it to the nodata value of the land cover raster. The model will properly handle nodata values.



Hello, thank you very much for your answer, here is my situation: 0 is not a valid land cover code. So I used a grid calculator to assign it to nodata, as shown in Figure 1.image
However, this problem still occurs during operation, which is the content of the picture of the question I asked for the first time. How can I solve this problem?

Hi @SMZ -

The command you show will change NoData to zero, so you will probably have a lot of 0 values in the resulting raster, which you can see in the raster attribute table, or when looking at Symbology or Min/Max values. You can use the Set Null or Reclass commands in ArcGIS to change 0 to NoData.

~ Stacie

Thank you again, and this software, a great software. My problem has been solved. Before that, the value of 0 in my current land use type map has not been modified.