InVEST 3.11.0 crashes on startup - Windows

Dear friends from Natural Capital communities,

The newest version 3.11.0 always crushes when launching. The version 3.10.2 could run successfully on my computer, but I’ve uninstalled it before installing version 3.11.0.

May I ask for a Installation package of InVEST 3.10.2 for Win10 64 bit system? I tried to find it on the Internet but failed.

Thank you in advance for your help and for creating this super resource.


1 Like

Hi @Ding, here is the installer for version 3.10. 2

Would you mind helping us try to figure out the problem with version 3.11.0? It may be a problem for other people also, so it’s important for us to understand the problem.

For version 3.11.0, did you choose the “new Workbench” or the “classic application”? InVEST | Natural Capital Project

Thanks for your help,


Thank you very much for providing the installer!

I downloaded both the “new Workbench” and the “classic application”, and different problems occurred when I tried to launch them.
For the “new Workbench”, the software blocked on the loading interface like this:

For the “classic application”, it always crushes when launching. Here is the screenshot (cut from the screen recording):

I am not sure whether those phenomenons are related to my installation and uninstallation of InVEST 3.10.2. I hope these feedbacks are helpful sincerely. Thanks for your effort in developing and improving InVEST!


Thanks so much for these details.

From the log in your screenshot, the issue might be the same one documented here: Scipy.interpolate.griddata Error : Exception ignored in: 'scipy.spatial.qhull._Qhull.__dealloc__' · Issue #8850 · scipy/scipy · GitHub

There is a suggestion that this OSError is raised if the path to your Windows TEMP folder contains non-Latin characters. That could happen if your Windows username contains non-Latin characters, for example. Is that the case for you?

For the Workbench, could you please check if you have any logfiles in the following directory, and upload them here if you do? There may be files named main.log and renderer.log.


Thanks again!

Yes. My Windows username indeed contains non-Latin characters .
Here is the logfile of Workbench. (3.6 KB)

Thank you for creating and refining InVEST again! :smiling_face_with_three_hearts:

Thank you @Ding , these logs are extremely helpful!

I can see the Workbench is having the same problem as the classic application. I suppose you could change the default the Temp folder path by changing the %TEMP% or %TMP% Environment Variables. But you really should not have to do that. This seems like a bug that should be fixed in Scipy.

1 Like

Hi @Ding,

I fully agree with @dave that this looks like a scipy bug.

Just to see if this works, could you try running InVEST as an administrator and seeing if that gives an error? I’m wondering if running as an adminstrator will use a different temporary directory and so might be a workaround.


Running InVEST 3.11.0 as an administrator does’t work, either. Here is the screenshot ( cut from the screen recording) :

Maybe it was caused by the same problem?
I hope this feedback is helpful to you.



how did you accquire your screenshot , my software imediately Flashback,so I did not screenshot,thanks a lot

the same with my “new Workbench”(win 7 ultimate edition 64 bit)

Yes. The flashback is immdiate. I used screen recording while running InVEST, and screenshot the logfile.

麻烦您给我发一下screen recording,以及如何截屏的,谢谢。

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.