Managed Timber Production - Can I still run the model?


I would like to know if I can still run the Managed Timber Production model from InVEST version 3.3.1. I tried to run a couple of times, but I got the same error (below). Can you please help me to clarify if it is a problem with my files or if the model is not available anymore? Thank you.

“WARNING an exception encountered when logging cannot connect: [Errno 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond”

natcap.invest.timber.timber-log-2022-04-18–15_19_12.txt (11.6 KB)

Hi @carolinah -

We stopped supporting the Timber model a long time ago. You should still be able to run it though if you really want to, although we can’t put much effort into troubleshooting. Taking a quick look at the log file, I see this error first:

Traceback (most recent call last):
File “C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.iui.executor”, line 560, in runModel
File “C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.timber.timber”, line 80, in execute
KeyError: ‘parcel_id’

The KeyError is probably the issue causing the model not to run, not the logging warning. This error is unfortunately vague, but if you search this forum for “KeyError”, you’ll see a lot of examples of why this kind of error happens, which might help you figure out what’s wrong. Sounds to me like something about the column names or formatting of the input CSV table (or perhaps a missing required column in the shapefile?)

~ Stacie


Hi @swolny,

Thank you very much for your help. I know that the model is not being supported by InVEST anymore, but I would be grateful if you can still help me. I could get the previous error right, the csv file was with semicolon and not comma, but I am getting the following error and could not find anything similar in the forum.

“ValueError: Illegal field requested in GetField()”
natcap.invest.timber.timber-log-2022-04-22–12_57_15.txt (6.2 KB)

Thank you again.

Hi @carolinah,
I think the timber model expects your timber parcels vector to have an attribute called Parcl_ID (note the missing e) that contains a unique ID number for each parcel. Unfortunately that isn’t documented, but since the model is no longer supported that’s unlikely to change.


Hi @esoth,

It worked! Thank you for your reply and help.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.