Memory Error Urban Cooling Model

Dear users and developers,

I am running the Urban cooling model and encountered a Memory error.

Looking at the log, the first error message was: “Task.add_task(731) ERROR Something went wrong when adding task calculate T air (5), terminating taskgraph” and then memory errors after that.

And It is my first attempt to use InVEST and I am running the model with 0.8m resolution for LULC and et0 with different resolution. I was wondering if there is a problem with working with two different raster resolutions.

Any help is appreciated!

Thank you

Hi @carson, thanks for letting us know about this issue, and welcome to the forums!

Could you attach the logfile from this run? The logfile is a .txt file located in your workspace directory and will be really helpful in pinning down the source of this issue.


InVEST-Urban-Cooling-Model-log-2020-10-30–18_32_07.txt (1.7 MB)

Hi @jdouglass, my bad!! Here it is.

I’m looking forward to your reply.
Thanks in advance,

No worries, and thanks for the logfile!

The model will resample all of your inputs to the same resolution early on in the model’s execution, so the error shouldn’t be related to the resolutions being different.

So, this particular error is related to a convolution that’s a part of the model, and this sort of error does come up with very fine-scale resolutions. This specific error looks a lot like something we’re right in the middle of fixing and that will be included in the next release of InVEST (3.9.0) in the next few weeks.

In the meantime, there are two main things you could try:

  1. Run the model at a coarser resolution This isn’t a fix, but if you don’t need the extra-fine resolution, the model will definitely run faster and you might avoid the memory error entirely by running the model at a coarser resolution.
  2. Try this development build This also doesn’t directly fix the issue, but it does raise the ceiling of the amount of memory that can be addressed. Keep in mind that if the model’s memory usage exceeeds the amount of memory available on your system, the model will run exceptionally slow … and if that’s the case, then the next best thing will be to wait until we finish the memory fix in InVEST 3.9.0.

Let us know how this goes for you!


I tried with a not so coarse resolution (5m) and it worked perfectly.

Thanks for the support!!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.