Urban cooling: Something went wrong when adding task calculate T air (5)

What is the issue or question you have?

My issue is similar to issue titled ‘Memory Error Urban Cooling Model’. I have a 1m resolution LU tif that results un runtime errors until its resampled all the way to 8m. The difference in my issue is that I get permission denied errors, not memory errors in the subsequent error text. Log file attached. I am on InVEST 3.12.0

If it useful, my ET layer is already at a much courser resolution.

I am a newbie. Any advice appreciated,

What do you expect to happen?

Complete the UC model run

What have you tried so far?

resampling this LU layer - success. Other courser LU layers - success. Delete intermediate folder - no change

Attach the logfile here:

2023-01-27 08:50:05,801 (pygeoprocessing.geoprocessing) geoprocessing.convolve_2d(2842) INFO convolution nodata normalize 100.0% complete on cc_park_POC2.tif
2023-01-27 08:50:05,961 (taskgraph.Task) Task.add_task(706) ERROR Something went wrong when adding task calculate T air (5), terminating taskgraph.
Traceback (most recent call last):
File “taskgraph\Task.py”, line 674, in add_task
File “taskgraph\Task.py”, line 1093, in _call
File “natcap\invest\urban_cooling_model.py”, line 1406, in convolve_2d_by_exponential
File “shutil.py”, line 749, in rmtree
File “shutil.py”, line 623, in _rmtree_unsafe
File “shutil.py”, line 621, in _rmtree_unsafe
PermissionError: [WinError 5] Access is denied: ‘D:\Invest\Cooling_Output\intermediate\tmpn3tg5e6b’
2023-01-27 08:50:05,963 (natcap.invest.utils) utils.prepare_workspace(166) ERROR Exception while execut

InVEST-natcap.invest.urban_cooling_model-log-2023-01-27–08_49_54.txt (7.8 KB)

1 Like

update: probably resource related as I’ve found running on a 1% of the original raster , with the 1m resolution, works. However my study area is only 5km square and I’d really like to use the high res LU so any help much appreciated.

Hi @southplainfield,
Thanks for reporting this! Could you try running InVEST using the “Run as administrator” option (in the right-click menu of the InVEST shortcut) and let us know if that changes anything?

The same error has occurred. Log attached.

InVEST-natcap.invest.urban_cooling_model-log-2023-01-31–09_00_25.txt (15.3 KB)

Thanks for including your logfile @southplainfield ! Is there any chance that you have a 3rd-party backup service such as dropbox, onedrive, backblaze or the like monitoring the folder that you’re selecting as your workspace? Windows is very picky about deleting files that are open in other applications, and automated sync solutions are prone to this issue with applications like InVEST that remove some of their temporary files as they go.

If so, the workaround will be to exclude the InVEST workspace from your desktop sync application.

If this isn’t the case, let us know so we can keep debugging!

1 Like

genius! that worked. thanks so much.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.