SDR InVEST 3.8.0 software closing abruptly

Hi All,

Congratulations to NatCap on new modules in InVEST 3.8.0!

I used the SDR in this version but for some reason, the model will execute and run but in the middle the application closes. I tried doing this in 4 different computers and happened to all. All computers have at least 150GB memory left so I don’t think it is an “out of disk space” problem. I also tried resampling all my raster files into 32m to check if it’s just the spatial resolution but it still is crashing.

I have been using 3.5 and 3.7 versions before and it’s good. I tried doing the same process now with the old versions and it still does the same. I also tried reinstalling the softwares but still ended up the same.

Any idea why is this happening?

Thanks!

Hey @carlureta,

Thanks for using the latest version and sorry you’re having some issues. Does the SDR run create a text log file in the output workspace directory? Should be something like my-workspace/InVEST-SDR-log-2020-02-20–09_44_45.txt. If so, could you attach that file to this forum thread? It’s possible there is a segmentation fault happening and hopefully that log file can help lead us to the problem.

Thanks,

Doug

Hi Doug,

Thank you so much for responding.
Here are the log files. I made 4 runs and they all stopped at some point.
Hope this helps in figuring things out.

InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2020-03-01–01_25_02.txt (26.5 KB) [InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2020-03-01–01_51_35.txt|attachment]
(upload://c1TU5ZdcNVYnAsXzQNnf03xL6PX.txt) (1.4 KB) InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2020-03-01–03_12_47.txt (1.4 KB) InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2020-03-01–03_42_37.txt (1.4 KB)

@carlureta,

This is an interesting one! There seems to be some suspicious warnings that are occurring that might be the cause of the problem. Did you say that you ran this exact input stack on the 3.7 version and had no problems? If you’re able to, it would be helpful if you could zip up your data inputs and email them to us so we can walk through what is happening. You could send them to ddenu@stanford.edu.

Let us know!

Yes. I ran it in 3.7 and it gave me the same results.
I also ran it in 4 different computers to see if maybe it is a hardware problem, both in 3.7 and 3.8 versions, but still same. Will send you the data inputs immediately.

Thank you so much for attending to this.

Hi Doug,

I sent you the files in your email yesterday.
Sorry to follow up but any thoughts on the issue?

Thanks!

Hi @carlureta,

I received your files and we have started to look into the issue. It appears to be a memory issue of some kind and are working on debugging the problem. It could be a tricky one to work through but I’ll post back here once we have an idea on what is going on.

More soon,

Doug

Great. Thank you so much for your efforts. Looking forward to your updates.

Cheers!
Carl

Hey @carlureta

I’m going to paste the follow up email you sent me here for other users to reference. Currently @rich is looking into the issue. Thanks for the update and we hope to get more info to you soon!

Apologies for this follow up. Were you able to figure out this issue?
I tried subdividing the basin into smaller sub-basins and the SDR worked for most of it.
However, the same problem occurred when I was doing it for a specific sub-basin (attached here are the dataset (SC_SubBasin_8c) and the log file (SDR_2018_SCSubB8c) for your reference ).
I thought it was just because of the scale but when I ran a relatively larger sub-basin, the larger one completed the task without problems.
Wanted to give you this update as it might help you in your troubleshooting.
Looking forward to hearing from you.

Note, the attachments have NOT been re-posted here.

Doug

Hi @carlureta,

I’m re-posting a message I just sent to another thread that might also help with the issue you saw here.

Just thought I’d send an update here. We are still actively looking into this issue but in the meantime we have seen some success when pre-filling the DEM for sinks or pits. We are doing this using the Fill Sinks (Wang & Liu) tool in the QGIS tooblbox.

Could you try filling the sinks or pits of your DEM and then using that DEM to run the SDR model?

Cheers,

Doug

thanks @dcdenu4.
Will do your suggestion and let you know.