Sediment Delivery Ratio model hangs on Mac

Hi, I am trying to do SDR in InVEST 3.7. I run the model for 8 hours, but this is the only thing showing up. Almost all of my inputs are good, but I don’t know why this shows up. Please Help. Thank you in advance!

Hi @anniemaeinson, offhand, I’m not sure what’s happening here, but the model probably should have done something in less than 8 hours :slight_smile: Could you share your inputs with us so we can try to reproduce this issue on our end?


1 Like

These are my inputs:

  1. the DEM raster file of the watershed
  2. rainfall erosivity index in raster file
  3. soil erodibility index in raster file
  4. LULC raster file
  5. watershed boundary (in shp file)
  6. biophysical table (I followed the right column title)
  7. Threshold flow accumulation (1000)
  8. borseli k parameter (1.096)
  9. Borseli IC0 parameter (0.5)
  10. Max SDR value (0.8)

Here’s the log file:

InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2019-09-16–09_37_55.txt (1.3 KB)

Thank you very much. This is my first time using InVEST, so I appreciate your help very much.

Hello, I recently tried to run the program in a windows computer, and this came up:

InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2019-09-23–09_07_15.txt (6.6 KB)

Well, still not sure what’s going on in the mac build there. If you can attach your inputs (or send them via google drive, dropbox or the like) we can try to reproduce the issue.

In any case, the second error log looks like there are pixel values of -infinity in your landcover raster, and -infinity (-3.402823e28) is not in your landcover csv. Could you check and make sure that this is a valid value for your raster? Often times values like this are supposed to be nodata values, but the nodata value of the raster isn’t actually set correctly.

Let us know how this goes,

Dear all and Jdouglass,

I also got some error when I have simulated SDR v.3.3 too. I have been running for a few hour and then it stop running. For more information, Pls kindly have a look at this log file. natcap.invest.sdr-log-2019-11-06–13_19_13.txt (16.9 KB)

I am thank you in advance for your supports.

Best regards,

Hi @Pheaktra -

3.3 is a very old version of InVEST. Please try the latest version (3.7), see if anything changes and let us know what happens. If SDR takes a long time to run, it’s often because your DEM is very large and/or high-resolution, and newer versions might handle it better.

~ Stacie

Thank you for your reply. I will try and let you know.

Hi everyone,
I have the same problem.
I tried to run SDR with InVEST 3.7.0 on macOS Mojave (Version 10.14.6).
I quit after 8 hours and this is all it did.

InVEST-Sediment-Delivery-Ratio-Model-(SDR)-log-2019-12-15–23_56_27.txt (1.4 KB)

@swolny you say the long running time is because of a very large DEM. The size of my DEM is 408KB, is this very large? I tried with a lower resolution but still it didn’t progress

Hi all,

We recently got to the bottom of this issue. A fix is forthcoming, but for now there is a workaround I can suggest. The problem is related to multiple processes trying to write log messages to the same place at the same time. It only affects Mac users running SDR with the user-interface.

The workaround:
Go to File > Settings and change Dialog logging threshold to WARNING.

This prevents InVEST from trying to write the problematic logs to the user interface. A complete logfile will still be written to your output workspace, just not to the dialog box of the user interace.
Also, this setting controls all InVEST models, so you may wish to set it back if you run other models.

1 Like