SDR Model in (inVEST version 3.10.2) gives an error (FileNotFound)

Hello guys!

I’m new to inVEST and I would like to test the gura example with the Sediment Delivery Ratio model.

But I created my workspace and open all the files (DEM, Erosivity, etc…) but when I run I got this error:

What could it be?

Many thanks in advance
João Santos

1 Like

Hi João -

That is an odd error, it almost looks like the model created the log file, then it somehow disappeared, so it’s giving an error trying to write to it. Is it possible that the log file got deleted, or perhaps opened in an editor? Another idea: is your Workspace a local drive or network drive? It’s possible that a network drive could have connection issues.

In general, it’s most helpful if you post the entire log file (the .txt file that the error is referring to) when reporting an error, since there might be additional information in there that can help us troubleshoot.

~ Stacie

Dear Stacie

The problem is that I dont know were to find the log file (it seems as you said that it has been created and immediately has been erased). I search also in the temp and cache folders and nothing. I cleared parameters cache and rerun and it continues to give the same error.

But now I installed and test it in my mac and it run with the Gura Watershed example. The results are in this log txt file:

InVEST-Sediment-Delivery-Ratio-log-2022-05-19–14_13_12.txt (37.5 KB)

Now I would like to run in my research case which is an island watershed were a floodplain analysis is being worked with HEC- Ras. I don’t have any sediment and/or debris calibration data but we need to consider a fixed sediment elevation in Ras model (we are starting with 1D modelling for start). My ideia is to obtain the sediment export raster (amount of sediments that enters in the stream network) for the basin outlet and then calculate the total catchment sediment export (E) which comes in ton/(ha.y) and convert it to a volume trough a weight/ volume relation based on the average composition of the soil. Then divide this sediment volume by the main channel area of the reach and I got a sediment elevation to be considered downstream, on the part of the reach that it is known to accumulate sediments due to its topographic profile.

Its true that the USLE model its not prone to be applied on a single event simulation but rather on a yearly averaged basis, but in this case the watershed slopes are very pronounced (more than 10%) and historic storm records shows that huge amounts of sediments could be distributed throughout the downstream part of this reach.

I really appreciate your comments and opinion.

Best Regards
João Santos

@JoaoFiSantos the FileNotFound error is very strange. What did you set as the original workspace on your windows computer? Could you screenshot the model inputs pane and share that with us? The model usually creates the workspace for you before it tries to open the logfile for writing, but it looks like something went wrong here and we don’t have much information to go off of.

I’m glad the model is running on your mac, anyways.

I’ll have to defer to @swolny for the other part of your question.



Sorry for the delay but I was schedule to other urgent matters.

I share with you the models input pane. The original workspace is in my hardrive:

Thank you very much for your help, I will appreciate.

Not a problem! This error is very strange. Thanks for sharing your inputs pane, and I don’t see anything unexpected.

So, this error is saying that a file or folder doesn’t exist when it’s expected to. Could you try creating the workspace directory if it isn’t already there? If that doesn’t do the trick, then I’m a little worried that there’s something else going on preventing the logfile from being created. I suppose a similar error might be raised if the file could not be created (like if there’s a permissions issue where Windows can’t write to the file because it’s open in another program), but that error is usually a different exception than FileNotFound.

When you have a few minutes to try this again, is there anything printed to the command-prompt? Sometimes there’s additional debugging text printed there.