Urban Nature Access model : TypeError: Wrong number or type of arguments for overloaded function 'Feature_SetField'

What is the issue or question you have?

I have this error that seems to be related to my shapefile (multipolygons) of the administrative boundaries. In my case the administrative boundaries is the census disctricts.
I’ve tested Invest with another random shapefile (parks instead of the administratives boundaries) and it worked without errors so I suppose it’s linked to my administrative boundaries file (census district file).

What do you expect to happen?

The model to work.

What have you tried so far?

I reprojected the file into the correct CRS.
I deleted the multipart feature (with the Topology Checker Panel in QGIS).
I’ve also ran the model with the shapefile after having deleted all the fields of the shapefile.

Attach the logfile here:

InVEST-natcap.invest.urban_nature_access-log-2023-06-22–12_16_17.txt (36.7 KB)

Welcome to the forums, @Francoise !

This is a really interesting error. So yes, the issue is somewhere in your admin boundaries vector, most likely with the type or value of a field, but unfortunately I can’t tell what the specific issue is just from the logfile. Could you share your complete stack of inputs with jdouglass@stanford.edu so I can take a closer look?


Thanks for sending your data @Francoise ! I don’t have a solution yet, but I have a hunch. Could you try this development build of the InVEST workbench and attach the resulting logfile from the run? It’ll still crash, but it’ll have more information.



1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.