Visitation Model: Linear model is under constrained with DOF=-1

When running the regression, I keep getting the warning that the regression is using the mean of an empty slice, followed by an error that the model runs into an invalid value encountered in double_scalars and that the linear model is under constrained with DOF=-1.

This leads to all empty outputs. I first ran into this problem when using fewer inputs and thought that it might have to do with a cell size that is too small or a lack of data, and that the error in double scalars might have been a division by 0. However, I later added additional inputs to more fully populate the country boundary and played around with the cell size (10km-100km), but have encountered the same error. I then tried this with different countries and have gotten the same result.

InVEST-natcap.invest.recreation.recmodel_client-log-2022-12-19–21_31_00.txt (6.8 KB)

I can’t be sure without seeing your data, but this could happen if your predictor table isn’t filled out correctly.


My predictor table is shown below. I looked over it again but don’t notice anything glaring. Could it be that I should not have labelled the tab? (I also took two variables out here so that the model would run quicker)



Hi @emmer,

Sorry for the delay over the end of year break. Are you still experiencing this issue? Could you zip up your input data and share it with us so we can try to reproduce it on our end? If it can’t be uploaded here you can use a file sharing service like Google Drive or email to


1 Like

I would also examine the attribute table of predictor_data.shp output. If there are a lot missing values, that could be the cause of the error, I think. It’s hard to say what the cause of the missing values would be, but it could be something like a predictor that doesn’t overlap with the AOI.

1 Like