Visitation: recreation and tourism model URLError

Dear NatCap Software support,

I am a PhD student, and I am using InVEST model for my research. I encountered an error while running the model. I have attached the log file and a screenshot of the error message. I would appreciate your assistance to solve this issue.


InVEST-natcap.invest.recreation.recmodel_client-log-2024-05-19–10_23_44.txt (1.7 KB)

Hi @Mitra.Gh , thank you for posting here. I’m sorry this model is not working for you. This model uses some Google Cloud services, and I wonder if Google is blocking access from your country. If that is the case, I’m sorry, and I’m afraid we do not have a solution at the moment. Here is a list of places where Google services may be blocked. Google Maps Platform Prohibited Territories  |  Google Cloud

Perhaps if you can use a VPN service that might work?


Dear Dave,

Thank you for your prompt reply. One of my friends who lives in France tried this model, but unfortunately, we encountered the same error. I’ve sent the log file and appreciate your guidance on how to address this issue.

Best Regards,

InVEST-natcap.invest.recreation.recmodel_client-log-2024-05-21–11_26_43.txt (4.08 KB)

Hi @Mitra.Gh , thank you for sharing this new logfile. That actually looks like a slightly different error, and I think it could be resolved if you can convince your friend to upgrade to the latest version of InVEST. From the log, I can see they ran version 3.12.0.

Dear Alberto,

I shared the log file you sent to me and this is the InVEST support team’ reply. According to their advice, the error you faced can be solved by updating the software to the latest version, which is 3.14.1. I hope this solution will work.

Thank you for your time and assistance.

Best Regards,

A post was split to a new topic: Changing threat weights, impact on results