Visitation: Recreation and Tourism - Connection error

Hello all,

I keep receiving a connection to the server error. It does this with both my personal data and the sample data by InVEST.
Attached is the log file.

InVEST-natcap.invest.recreation.recmodel_client-log-2024-06-11–10_58_28.txt (4.9 KB)

Hi Stalo, thanks for reaching out. I see one issue in your log gile, but not sure if it’s the problem. Note this…

“Recorded path not in target path list f:\phd_second chapter_eocsystem services\visitation_recreation_tourism_model\intermediate\aoi_500m.shp”

There is a space in the folder name between “second” and “chapter”. Replace the space with an underscore and try again. Then let me know how it goes.

@Stalo could you try running the model again? While we do usually recommend not having spaces in filepaths because it can cause issues as @Nadine mentioned, the specific error appears to be related to connecting to the recreation model’s server. I was just now able to run the recreation model, so the server appears to be online. If you use a VPN, are you able to run the model? If so, then there is likely a firewall rule preventing the InVEST desktop application from running the recreation model.


Hi Nadine, thank you for your response. I did manage to run the model without doing changes in the folder’s name, but I did change my location (i.e. at the university it wouldn’t work but when i tried it at home it worked from the first time). So probably something to do with the vpn?

Yes, this was probably the problem. I did manage to ran the model at home, whilst at the uni it wasn’t possible.

OK! Then the most likely cause of the issue is a firewall rule set up by the university’s IT department that is preventing you from running the model there. Glad to hear that you were able to run the model.

Great, glad it’s working for you now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.