Why does InVEST_3.6.0_x86 kinda disappears itself in a Win10 PC?

Hi Everyone,

Hope you are fine and doing well these days.
I noticed that after successful installing/using of InVEST_3.6.0_x86 over my win10 PC, it would stop working after a few weeks!!
I mean I can still see the software is okay and listed in my PC’s control panel, but when I click on any of InVEST modules (e.g. water yield, delineator, etc.), an error appears and it just simply wouldn’t work as if someone deleted the whole application files!
A fresh new reinstall is gonna solve it, but it just keeps happening for an unknown reason and its tragic :frowning:
My PC works at its top performance, so any idea is highly appreciated.

Hi @Behzad_AK,

Thanks for posting to the forums. This sounds like a strange issue indeed. You mention that an error appears, is it possible to capture what that error was?

Normally I might say that an antivirus program might be blocking or limiting InVEST in some capacity, but the fact that you can successfully run the models initially makes me think this isn’t the case.

InVEST 3.6. is a fairly old version of InVEST at this point. Have you tried downloading the latest 3.8.9 version? There have been a lot of bug fixes and model improvements since 3.6. If you could install the latest version of InVEST and let us know if you see the same behavior that would be really helpful.



1 Like

Hi Behazad,

I had the same annoying problem!.

It went away after I did several major updates of Win 10…Good Luck!


Hi @laura78,

Thanks for posting and letting us know this isn’t an isolated incident! Could you provide more information on what would happen after Windows updates? Would the models not launch or would the installed InVEST be uninstalled…? Any additional information could help point us to what might be the main issue here.



Hi Doug,
What’s up? Thanks for your time considering my question.
Yeah I’ve tried to install/reinstall InVEST many times. I found that my antivirus (McAfee) detects some unusual activities upon the very first launch of InVEST then quarantine probably some crucial files, so my Invest crushes as soon as I re-launch it :frowning:
Honestly it’s not fair that my antivirus tries to quarantine the InVEST files, while I’ve been staying in quarantine myself! Ok, back to the topic now, I think that’s pretty much it and I’m gonna try the latest version of InVEST. Hope it gonna have les fiction with my antivirus. Lol
Lastly, I noticed that this whole story is happening since lately, cause I’ve been using the same computer, same antivirus, etc. Nothing has changed at all. It would be absolute great if we could find why does this keep happening!!

Thanks again,
Stay safe

Hi Laura,
Hope you’re doing fine.
I did noticed that somehow my antivirus tries to quarantine InVEST files, so it would crash and wouldn’t start anymore.
That’s kinda strange, cause I’ve been using InVEST on the same PC and this is a fault what I’m facing recently.
Anyway, I did restored the quarantined file from my antivirus, but it keeps quarantine them again and again. I’m gonna try the latest version of InVEST. Please let me know if it also happens for you, too?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.