InVEST 3.8.9 does not work or open

Can someone help me get the model to open up? It seems to just go to a black screen and then go away immediately.

1 Like

Hi @cnovotny85,

Thanks for posting to the forums and trying InVEST. Can you provide a little more information?

  • What Operating System and version are you using, Windows 10 or Mac-Catalina?
  • Which version of InVEST did you download?
  • Do all the models result in a black screen that disappears?



Windows 10 Version 1909
I tried 3.8.1, 3.8.8, and 3.8.9, but all three gave the same issue.

Hi @cnovotny85 In order to troubleshoot further, could you try the following:

  1. Open cmd.exe
  2. cd into the InVEST installation directory (usually under something like C:\InVEST_3.8.9-x86\invest-3-x86 )
  3. Execute this command: .\invest.exe run carbon
  4. Copy the text of the error printed to the cmd window into this thread so we can take a look.


1 Like

Where is cmd.exe? It was not part of the files that came with the download.

I figured out what cmd.exe is and followed the instructions. Why do I have to use cdm.exe to make this software run? Why can’t I double click the icon like normal and have it load up?

Is there a way to open up the file from the folder itself rather than having to use this cmd thing to make the software run?

Hi @cnovotny85 -

Most of the time, we can launch the models from the Windows Start menu, just like other apps. When this doesn’t work properly for someone, running it from the command line might provide information to help the software team understand why, and troubleshoot to find a solution, so you can run it from the Start menu in the future. Hopefully, running it from the command line at least lets you get on with your work for the moment.

Just to set expectations, Stanford is closed for Thanksgiving holiday until Monday, 11/30, so we are all away right now and will look further into this issue when we return. In the meantime, have you tried searching this forum to see if there are any related threads that might help?

~ Stacie

1 Like

Thanks for your patience, @cnovotny85. A few more questions to help us figure this out:

When you used cmd.exe and entered the command invest.exe run carbon - is any text printed to the black cmd window? Could you copy/paste anything you see there and leave it here?

Which model were you trying to open to begin with? Are you able to open that model with a similiar command like invest.exe run some_other_model? Use invest.exe list to see a list of all the model names that can be passed to the invest.exe run command. Is there any text from the cmd window that you can copy/paste?



Oh, and you may also try adding --debug to those commands, which may give us extra information.

For example, invest.exe --debug run carbon

Can we book some time to help work through this problem over share screen? I just downloaded 3.9.0 and the same problem.

Hi @cnovotny85 ,

Sorry you’re still experiencing issues with this. We’re a pretty small team with limited resources so we don’t necessarily provide scheduled screen share troubleshooting. We’re happy to help over these forums though.

Could you try some of the same recommendations that @dave mentioned before? Specifically running invest.exe --debug run sdr from cmd.exe like you did before? If you could copy and paste here what is output in the black console that would be the most helpful to start.

Like Dave mentioned as well, you can run invest.exe list to display the available model names to call in this way.

Sorry for this complicated debug process but hopefully we can get it sorted out! Thanks for helping make InVEST better.


1 Like

@cnovotny85 , I’ve just patched this version of InVEST to have the command prompt stay open longer if an error causes it to crash unexpectedly. Could you try it and see if the error is presented there? Please be sure to include the text that it shows and we’ll see if we can debug further from there.

Here’s the download:


1 Like

Heyo @jdouglass I am having the same issue when I install the InVEST software! I have also tried the steps you’ve outlined above but still no luck! Have you got any more ideas?

1 Like

Hi @timber , did you download the version James linked above? Or did you try running a model from the command prompt with a command like: invest.exe --debug run sdr ?

Either way, does any text appear in the black cmd window? If you can paste that text here we can try to figure out what’s going wrong.


1 Like

Hi @dave I have tried both now; if I put the command prompt in I receive this back “‘invest.exe’ is not recognized as an internal or external command,
operable program or batch file.”. When I download with the link @jdouglass provided the invest.exe file still comes up as a blank cmd screen.

Do you have any other tactics?

Hi @timber , thanks for trying. To get that command to work, you’ll need to direct the command prompt to the location of the invest.exe file.

For me, after installing invest, the file is at C:\InVEST_3.9.0_x64\invest-3-x64\invest.exe. It might be slightly different for you. So you could replace invest.exe with this entire path when you run the command. Or you could first change directories to the directory containing invest.exe using the cd command. If you continue seeing the same “not recognized…” message, it means you haven’t quite gotten the correct path to the file.

Hey @dave thanks again, I appreciate your patience! I have tried re-installing and copying pathway address but still no luck. Could the issue be that I am running Windows 10 so the software is incompatible with this version? I have just run a troubleshoot and it seemed to indicate that the InVEST program wasn’t compatible with the computer? :cowboy_hat_face