About annual water yield result

Thanks in advance to those who have answered my questions. i have tryed sevral times that never succeed. i put the date into the model with the same coordinates and distinguishability.But the results of water yeild are so small.its only 17,its weird. i would be grateful if you can answer my question.

Hi @lif ,

Thanks for posting and welcome to the forum. Could you mention which version of InVEST you are running?

Could you also share more about your study area, data inputs, and what you expect to see for water yield volume output?

Thanks!

Doug

thank you so so so much for your response.

firstly I’m running the invest 3.9.0. Then my study area is about a province. I have looked some statistical dates that a province’s annual water yield is probably 1637 billion cubic meters. so I’m looking forward this result. and now my result is far away from it.

l have checked my dates yesterday and find my raster size are very small. seems only 0.0028 ,but the raster distinguishability is 1:1 ,I don’t know if it will matter the result. ps. I want to ask ,dose the area date will influence the result? I learned the size of area will not affect the result. thans again. And forgive my poor English.

Hi @lif ,

No problem, thanks for sharing that information. As long as your rasters are projected in linear units of meters it should not matter what the pixel sizes are.

At this point it would probably be easiest if you could share your input data. If you are able to share it, could you put all your input files in a zip file and share it via Google drive, dropbox, or another cloud sharing service?

Best,

Doug

hi,I had the same problem.The model worked, but my water yield was zero.May I ask if you have solved the problem?I’m using version 3.9.
Looking forward to your reply, thanks!

HI @SLDX ,

It’s hard to know why you might be seeing 0 water yield in the output. The easiest thing would be for you to share your inputs if that’s possible. Could you share you inputs in a zip file via Google drive, or dropbox, or another sharing service?

Thanks,

Doug

Of course, please tell me an email account of yours, and I will send it to you by email, around 10 a.m. Beijing time on August 13, 2021.Because now China time is almost 11 o’clock in the evening.
Thank you for your help! I will describe my problem in detail again in the email.

[



牙子

邮箱201604630@stu.ncwu.edu.cn
China
450046

](头像签名)

签名由 网易邮箱大师 定制

Hey All,

My email is ddenu@stanford.edu if you’d like to try and send zipped inputs that way!

Thanks,

Doug

Hi,I have sent the data to you through email.My email account is 201604630@stu.ncwu.edu.cn
Please take the time to help me.thank you!

thankyou again,and luckily,i have solved my problem.

1 Like

hello,have you solved you problem?and i think you are a chinese right.可能用中文交流更快

全中文好像发不出去Could you add wechat communication? My wechat ID is X20201010042

Hi @SLDX ,

Thanks for your patience and for @lif reminding me of this issue. I took a look at your data and found that there was some nan (not a number) values in your depth to root raster xj_depth.tif. These nan values were causing the issues for the wyield outputs.

I replaced the nan values with nodata and re-ran the model with successful outputs. Please find attached the fixed root to depth layer. Could you try using this and seeing if it works for you?

xj_depth_fixed.tif (17.5 KB)

Doug

1 Like

Thanks for your help! It’s working !I wish you a happy life. Thanks!

3 Likes

Thanks for your help! It’s working !I wish you a happy life.

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.