Carbon model output not matching with the input land use class

Hi there,

Apologies if this has been asked already, I did have a search but couldn’t find anything.

I using InVEST carbon to look at current carbon storage in arable, improved grassland and deciduous woodland (for now, I will be generating LUC scenarios at a later date). I ran my model no problems, however when I look at the output in GIS, the outputs and values are incorrect. Let me explain.

Above is my land cover map with the carbon output. The grassland and arable (purple and blue) have no carbon shading, even though I included carbon values in the pool table. Yet suburban (covered by the red) is supposedly the highest carbon storage (even though I had values of 0 for all pools for suburban). In comparison, the orange is deciduous woodland, which the model is saying is a medium carbon output. Basically, for some reason the model isn’t lining up correctly with the land code number I assign it.

Do you have any ideas? I would put more photos but as I’m a new user the forum won’t let me, hopefully I can put more pictures up in the comments.

Thank you

This is my original land cover map

This is the carbon pool table - you can see that I have assigned 0 to all land uses apart from arable, deciduous woodland and improved grassland

However, when I view the model output, I think it is assigning the deciduous carbon values to suburban, and other similar issues, hence why I have no value for improved grassland or arable carbon storage. Does anyone know how to fix this?

Just a note to say I’ve solved it! But I can’t work out how to delete this post.

1 Like

Hi @Kelpforestsea and welcome to the Forum,

I’m glad to hear that you were able to solve the problem. Others may encounter similar issues as you were having. What was the solution? Were the lucodes mixed up?


1 Like

Hi Jesse,
Yes the LUCs were mixed up. For UK land cover maps we have a set system of numbers for each LUC so 1 - deciduous, 2 - coniferous, 3 - arable etc. which in GIS these numbers come under and match with the “mode” when altering the symbology. However, the “value” numbers, which is what the model runs off, do not match up to our system, so I had to work out which number went with the correct land class.
Hope that helps someone in the future.