CSV File reading problem

Hi everyone,

I am currently working on the Annual Water yield problem and encountering a problem on the inputs when adding the biophysical table (the one I generated as well as when inserting the one that comes with the model example dataset), the error reads:

On other models, like urban flood risk, the software has no problem reading the csv files.

Currently working on Invest 3.11.0 version, but I have tried on an older version with the same error.

I would appreciate any help, thanks.

1 Like

Hi @kavica,

Welcome to the NatCap forums and thanks for posting. Would you be willing to share the CSV file you’re trying to use? If it’s an encoding issue they can be tricky to track down.



Sorry for the delayed response, sure, im sharing the CSV file, we are still adjusting the values for each column.
tabla_biofisica_2017.csv (291 Bytes)

Hi @kavica , thanks for sharing your file. It does seem like an encoding problem. If I open the file in Excel and Save as “CSV UTF-8 (Comma Delimited)” then the new file works for me.

There is another minor problem in the header of the file though:
“root_depth_kc” should be two separate columns: “root_depth, kc”

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.