MESH 0.9.0 error in biophysical table of annual water yield

I have installed MESH 0.9.0 and it ran fine with the NDR and SDR models. When I try to run the annual water yield model (that ran successfully in the 3.8.9. InVEST version), I keep having this error that won’t let me even start the run. I attach a screenshot. I have checked the biophysical table and each lucode corresponds to the classes in the raster of the LULC. Any idea why this happens?
Many thanks! Luisa!


Following up on this, I have managed to run the model, if anyone had the same issue. I don’t know what the problem was, but I just copied the table on a text file, from it I copied the table again to a new spreadsheet, and saved it as a csv file. It worked. Probably the text file passage cleaned it from some charactr that were not visible in the spreadsheet?
Is there a MESH guide available? I tried to follow some links from previous posts of other users of the community, but they do not seem to work…
Thanks a lot!!


Hi @luisagalgani,

I’m glad you were able to get the model to run! The \xef\xbb\xbf that you were seeing prefixed to the lucode field is the bytes order mark (BOM), which is at the beginning of files that are UTF8-BOM encoded. Copying it to a text file probably got rid of this.

MESH is using an outdated version (3.3.2) of InVEST. Since that version we have made many important updates and bugfixes, including handling UTF8-BOM encoded files, and some significant bugs with the models you are running (see the changelog). I’d recommend trying to get MESH to run with the latest InVEST version if you can. Maybe @jandrewjohnson would be able to help with this and/or point you to a user’s guide!

Hello @esoth! And thanks a lot for your reply. I know that MESH is using an outdated version of InVEST, I was just wondering how to be able to run it wih the latest updated version, is there something that I can directly do to switch to the new InVEST? I think I found a user’s guide online, is that correct?
Thanks a lot, have a good day!

Just wanted to chime in here, and it looks like you found the documentation @luisagalgani ! That looks like the latest version, as far as I can tell.

I just took a closer look at MESH itself, and while @esoth is very right that we fixed the Byte-Order Marker issue in a more recent version of InVEST, the version of InVEST included with MESH is unfortunately pinned to 3.3.2 and there isn’t a way to upgrade it. So if you’d like to use MESH, the application will unfortunately be stuck with using InVEST 3.3.2. It’s possible that a future release of MESH may update this, but for that I’ll need to defer to @jandrewjohnson. Sorry about this!


Thank you so mch, that’s ok, I managed to run MESH with the models so far, it seems that everything works. Otherwise I will ask for your help again!
Best wishes and thanks


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.