Error running urban cooling model with work productivity valuation

When trying to run the labor productivity and energy savings assessment model, I received an error that apparently did not appear when running the model without these assessments. The energy saving assessment results seem to be ok, considering the values appearing in the building vector attribute table, but the regular results in the hmi vector are not appearing. Including avg_cc and avg_t results are missing from the attribute table.

I ran the model a few days ago with the same parameters but without the evaluation models and this issue was not happening. The log gives a warning describing that a shape_area value was not written, because the number is too large relative to the field width, which I don’t think I can have control over, so I don’t really know what to do to get the correct value results.

Hope you guys can give me a hand on this!

The logfile:

InVEST-natcap.invest.urban_cooling_model-log-2023-09-05–13_57_37.txt (2.6 MB)

It looks like your buildings vector contains several features that have no geometry. There are several warnings about this earlier in the log:
WARNING no geometry in C:\Users\iecolab\Documents\Results_day\mod13\intermediate\reprojected_buildings_mod13_cooling.shp FID: 166750, skipping...

Some of your results are missing because the model exited with an error before it finished. You can see the error at the bottom of the log. The error is happening due to a missing geometry. You’ll need to correct or delete the building features that have no geometry.


Thank you very much @esoth!

Sorry for the delay in responding, but I tried checking geometry errors with different software and methods and nothing showed up. After a bit of research, I used GRASS to also check for topological errors and was able to find a lot of errors in the build vector. I’m not sure if these are the errors the model might be pointing out. I know these errors are different, but since I couldn’t find the geometries that might be missing, the only other problem I could imagine happening is this topological one. Any suggestions or tools I can use to resolve this issue?


Yeah, it isn’t completely surprising that geometry validity checks would think that a missing geometry is valid … in that case, validity would be vacuously true because the lack of a geometry prevents the validity check from being false.

I think your best bet for locating missing geometries will be to select the missing features using an expression and then removing those features in GIS. Here’s an example that demonstrates this in QGIS: select - Selecting features with NULL Geometry from Shapefiles using QGIS? - Geographic Information Systems Stack Exchange

Let us know how this goes!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.