HQ model error : partial model success

Hello, I am Nayeong
I am in big trouble with the HQ model result…
The model didn’t give me an error message, but results said it has some big big problem in there.
I run it about 20 times, the model says “success”, and then I open the quality output file, it is just a tiny part of the whole research site.

I searched hard for the same error on the Internet but could not find the same case…
Plz help me~
Here is the log file of the most recent model.
(Usually, I knew that I failed because the model produced a result in a short time, but this time it took a while to get output. But, it gave only partial results to me)

InVEST-Habitat-Quality-log-2019-09-06–11_38_07.txt (562.5 KB)

Hello Nayeong,

Welcome to the forums! Two possibilities come to mind:

  1. The only regions that will show up in your outputs are those where all your threat rasters have valid pixels. I strongly recommend that you do not use nodata values in your threat rasters and only use pixel values of 0 or 1.
  2. Your threat rasters might not only overlap in a very small region, which will lead to your outputs being cropped to the intersection of all of the bounding boxes.

Because of the runtime of your model run, I suspect the first option I mentioned is what’s happening.

By the way, we recently fixed a bug in Habitat Quality that was causing convolutions to not return expected results. This issue is fixed in this development version of InVEST: https://storage.googleapis.com/releases.naturalcapitalproject.org/invest/3.7.0.post366%2Bhc94dfedffddd/InVEST_3.7.0.post366%2Bhc94dfedffddd_x86_Setup.exe

I recommend upgrading to this development build.

If neither of those possibilities I mentioned make sense, could you share your data with us so we can take a look?