HRA preprocessor not generating spatially explicit values?

I am trying to run the HRA but the preprocessor is not generating the spatially explicit values in the resulting csv. Although everything is set up correctly (because it has worked well on previous runs), it now will only generate the csv without any “SHAPE” values in the appropriate boxes. It worked well on one dataset I had, then I tried to use another data and it would not generate spatially explicit criteria. Previously, I could go back to the first dataset and run it successfully again so I didn’t think it was a bug with InVEST… but now that original dataset won’t work anymore either even though nothing has changed about it.


Hi @jrudebusch,

Thanks for posting to the forums. This does sound like a strange issue, what version of InVEST are you running? Could you attach the logfile? If you’d be willing to share your data I could try running it on our end to make sure there isn’t a bugging popping up. If the data is small enough you could share a zip here, or via email ( ddenu @ stanford . edu). For larger datasets Google Drive usually works well for sharing a link.