InVEST 3.13.0 Crashing on Start on MacOS 12.4


I’ve been using InVEST 3.13.0 Workbench, but it’s recently been taking me to the error screen

when I open it. If it helps, I’m running InVEST on a MacOS 12.4 (Monterey). I’ve tried restarting my computer to no avail, and cannot decipher the error logs (see attached).

This started after I ran the Urban Cooling model and ran out of storage for intermediate files, though I’ve resolved that and should have enough storage to run InVEST properly (?).

Does anyone know what I should do to fix this? Thanks so much in advance!

-Alex (80.4 KB)

1 Like

Hi @alxhzhong , thanks so much for reporting this.

It looks like some data could have been corrupted when that urban cooling model run failed unexpectedly. We’ll try to fix that so it won’t happen again.

Could you please try,

  1. shut down the Workbench
  2. check your Activity Monitor to make sure there are no leftover processes running with names like “InVEST …” or “invest”.
  3. Delete this folder: /Users/<your username>/Library/Application Support/invest-workbench
  4. Open the Workbench again

Please let us know if that works,


Hi @dave , so sorry for the late reply. I followed the steps you outlined and they worked perfectly— thanks so much for your help!


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.